
For more information
Solution details: www.adobe.com/accessibility/products/acrobat/
Program details: www.adobe.com/accessibility
Contact information: access@adobe.com

Adobe Systems Incorporated 
345 Park Avenue 
San Jose, CA 95110-2704  
USA 
www.adobe.com

Adobe, the Adobe logo, Acrobat, Acrobat Connect, ActionScript, Adobe Captivate, Authorware, Flash, and JRun are either registered trademarks or trademarks of Adobe 
Systems Incorporated in the United States and/or other countries. Microsoft and Windows are either registered trademarks or trademarks of Microsoft Corporation in the  
United States and/or other countries. Java is a trademark or registered trademark of Sun Microsystems, Inc. in the United States and other countries. All other trademarks  
are the property of their respective owners.

© 2012 Adobe Systems Incorporated. All rights reserved. Printed in the USA.

 10/12

Adobe® Acrobat® XI Pro Accessibility Guide: 
Best Practices for PDF Accessibility



IIAdobe® Acrobat® XI Pro Accessibility Guide: Best Practices for PDF Accessibility

Contents
PDF Accessibility Overview.................................................................................................................................................. 1

Overview of Portable Document Format (PDF)........................................................................................................ 1

Determine the Accessibility Path for each PDF Document.................................................................................... 1

Start with an Accessible Document............................................................................................................................. 2

Characteristics of Accessible PDF files........................................................................................................................ 2

Adobe Acrobat and Adobe Reader Accessibility Features..................................................................................... 4

Accessibility Features of Adobe XI Reader, Adobe XI Standard, and Adobe XI Pro......................................... 5

The Acrobat XI Pro Accessibility Guide Series........................................................................................................... 6

Using the Acrobat XI Pro Accessibility Checker............................................................................................................... 7

The Make Accessible Action Wizard............................................................................................................................ 7

Accessibility Checker (Full Check)............................................................................................................................... 7

Additional Functional Validation Techniques.........................................................................................................23

WCAG 2.0 Mapng to PDF/UA.......................................................................................................................................24

Acrobat XI Pro PDF Accessibility Repair Workflow......................................................................................................30

Step 1: Examine the PDF File.......................................................................................................................................31

Step 2: Add Document Properties and Interactive Features...............................................................................31

	 Document Title, Subject, Author, and Keywords.................................................................................................32

	 Set Security That Permits Accessibility..................................................................................................................33

	 Create Accessible Links..............................................................................................................................................35

	 Add Bookmarks...........................................................................................................................................................36

	 Set Initial View/Open Options..................................................................................................................................37

Step 3: Perform OCR on Scanned Document..........................................................................................................37

	 How to Determine if a PDF File is a Scanned Document....................................................................................37

	 Perform OCR on a Scanned Document..................................................................................................................40

Step 4: Add Form Fields and Set the Tab Order......................................................................................................41

Step 5: Set the Document Language..........................................................................................................................41

	 Step 6: Add Tags to the Document..........................................................................................................................42

	 Determine if the Document has been Tagged......................................................................................................42

	 Add Tags to an Untagged Document......................................................................................................................49

Step 7: Examine and Repair the Tag Structure........................................................................................................52

	 Touch Up Reading Order Tool (TURO)....................................................................................................................53

	 Tips for using the Touch Up Reading Order Tool.................................................................................................56

	 Checking Read Order with the Touch Up Read Order Tool...............................................................................57

	 Edit Tags with the Touch Up Reading Order Tool.................................................................................................59

	 Using the Touch Up Reading Order Tool Table Editor........................................................................................62

	 Editng Table Tags.........................................................................................................................................................63

	 Remove or Replace Document Structure Tags using the Touch Up Reading Order Tool...........................66

	 Tags Panel......................................................................................................................................................................69



IIIAdobe® Acrobat® XI Pro Accessibility Guide: Best Practices for PDF Accessibility

	 Correct Table Tags with the Tags Panel..................................................................................................................74

Step 8: Add Alternative Text........................................................................................................................................76

	 Add Alternate Text and Supplementary Information to Tags...........................................................................76

Step 9: Use the Accessibility Checker to Evaluate the PDF File..........................................................................78

Acrobat XI Pro Accessible Forms and Interactive Documents...................................................................................80

Types of interactive PDF Form Fields........................................................................................................................81

Automatic Field Detection using the Acrobat Form Wizard................................................................................81

Creating a Form without the Forms Wizard.............................................................................................................83

Forms Editing Mode......................................................................................................................................................84

Selecting a New Form Field to Create.......................................................................................................................84

Form Field Properties...................................................................................................................................................86

Setting Tooltips for Form Fields..................................................................................................................................86

Editing or Modifying an Existing Form Field...........................................................................................................88

Deleting a Form Field....................................................................................................................................................88

Field Actions....................................................................................................................................................................89

Validation and Error Messages...................................................................................................................................89

Set the Tab Order............................................................................................................................................................89

Provide Instructions and Onscreen Labels..............................................................................................................90

Other Accessibility Considerations............................................................................................................................90



A document or application is considered accessible if meets certain technical criteria and can 
be used by people with disabilities. This includes access by people who are mobility impaired, 
blind, low vision, deaf, hard of hearing, or who have cognitive impairments. Accessibility 
features in Adobe Acrobat, Adobe Reader and in the Portable Document Format (PDF) make 
it easier for people with disabilities to use PDF documents and forms, with and without the aid 
of assistive technology software and devices such as screen readers, screen magnifiers, text-to-
speech software, speech recognition software, alternative input devices, Braille embossers, and 
refreshable Braille displays.

The Web Content Accessibility Guidelines (WCAG) 2.0 (ISO/IEC 40500:2012) and the PDF/
UA (ISO 14289-1) standard cover a wide range of recommendations for making content more 
accessible to people with disabilities. One benefit of following these guidelines is that content 
becomes more usable for all users. For example, the underlying document structure that makes 
it possible for a screen reader to properly read a PDF out loud also makes it possible for a mobile 
device to correctly reflow and display the document on a small screen. Similarly, the preset tab 
order of an accessible PDF form helps all users—not just users who rely on the keyboard—
complete the form more easily.

Overview of Portable Document Format (PDF)

The PDF format is the native file format of the Adobe® Acrobat® family of products. The goal of 
this format and these products is to enable users to exchange and view electronic documents 
easily and reliably, independently of the environment in which they were created. PDF relies 
on the same imaging model as the PostScript® page description language to describe text and 
graphics in a device-independent and resolution-independent manner. To improve performance 
for interactive viewing, PDF defines a more structured format than that used by most PostScript 
language programs. PDF also includes objects, such as annotations and hypertext links, that are 
not part of the page itself but that are useful for interactive viewing and document interchange.

A logical tagged structure tree is used within each document to provide a meaningful reading 
order for content, as well as a method for defining structural elements role and relationship to 
page content. Within this tag structure, other properties such as alternative text and replacement 
text can be provided.

Determine the Accessibility Path for each PDF Document

PDF files are created in a variety of ways, from a variety of applications, and for a variety 
of purposes. Achieving the desired accessibility goals for an individual PDF file requires 
understanding the nature of the PDF and its intended use. Adobe Acrobat XI Pro provides 
several tools including the Make Accessible Action wizard and the Accessibility Checker to assist 
authors in evaluating and fixing issues that can impact accessibility. 

The Adobe® Acrobat® XI Pro Accessibility Guide: PDF Accessibility Repair Workflow document 
provides details on how to assess existing PDF files for accessibility. By following these 
procedures in the recommended order, authors can efficiently proceed through the analysis of 

PDF Accessibility Overview
PDF file format accessibility features combined with Adobe® Acrobat® 
and Adobe Reader® allow universal access to documents
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a PDF file in a systematic fashion. Systematically ruling out or confirming certain characteristics 
found in a PDF file will guide the author to the most appropriate path for making an individual 
PDF document accessible.

Note: 	 These Best Practices techniques require access to Adobe Acrobat Pro XI for Windows. 
Adobe Reader XI and Adobe Acrobat XI Standard do not have the complete set of tools 
needed to create and validate PDF documents for accessibility.

Start with an Accessible Document

The PDF format is a destination file format. PDF files are typically created in some other 
application. Optimally document accessibility should begin in the native document format. 
For example, many documents are created in a word processing or desktop publishing 
application, and then exported as PDF documents. There many things that can be done in 
native document applications to support accessibility, such as adding alternative text for 
images; defining structural headings, lists, and data tables; providing document language; 
and setting document properties such as titles. Adobe desktop publishing applications such 
as Adobe InDesign and Framemaker support these features, as well as other word processing 
applications such as Microsoft Word. For information on building accessibility into documents 
created with Adobe products visit the Adobe Accessibility website. To gain assistance on 
adding accessibility into Microsoft Word documents prior to conversion to PDF format please 
visit the Microsoft Enable website. Making the native document accessible allows for less work 
when changes are made to the native document and the PDF document is regenerated.

If the native document is not available, in most cases, the document can still be made fully 
accessible. Without accessibility in the native format there will likely be more manual work 
required in the PDF to properly tag the document. There are some items such as choosing 
sufficient contrast between foreground and background colors that must be implemented in 
the native document.

Characteristics of Accessible PDF files

Accessible PDFs include but are not limited to the following characteristics:

Searchable text

A document that consists of scanned images of text is inherently inaccessible because the 
content of the document is a graphic representing the letters on the page, not searchable text. 
Assistive technology software cannot read or extract the words in a graphical representation. 
Furthermore, users cannot select or edit the text or manipulate the PDF for accessibility. 
Scanned images of text must be converted into to searchable text using optical character 
recognition (OCR) before addressing accessibility in the document.

Fonts that allow Characters to be Extracted to Text

The fonts in an accessible PDF must contain enough information for Acrobat to correctly extract 
all of the characters to text for purposes other than displaying text on the screen. Acrobat 
extracts characters to Unicode text when you read a PDF with a screen reader or the Read Out 
Loud tool, or when you save as text for a Braille embosser. This extraction fails if Acrobat cannot 
determine how to map the font to Unicode characters.

http://www.adobe.com/accessibility/
http://www.microsoft.com/enable/
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Interactive Labeled Form Fields with Accessible Error Messages and No Timing

Some PDFs contain interactive forms that people fill out using a computer. To be accessible, 
form fields must be interactive; that is, a user must be able to enter values into the form fields. 
Interactive PDF forms also have a defined tab order which allows users of assistive technology 
to use the Tab key in order to progress from one form field or interactive control to the next in 
a logical manner. Refer to the document Adobe® Acrobat® XI Pro Accessibility Guide: Creating 
Accessible Forms for complete details. Forms must provide identification, give tips on proper 
completion, and prevent errors. Form entry should not be timed unless the user can request 
more time.

Other Interactive Features: Hyperlinks and Navigational Aids

Navigational aids in a PDF—such as links, bookmarks, headings, a table of contents, and a preset 
tab order for form fields—assist all users in using the document without having to read through 
the entire document, word by word. Bookmarks are especially useful and can be created from 
document headings. These features can be accessed using the keyboard without relying on the 
mouse, and allow for multiple way for users to navigation content.

Document Language and Title Indication

Specifying the document language in a PDF enables some screen readers to switch the current 
speech synthesizer to the appropriate language, allowing correct pronunciation of content 
in different languages. Providing a document title allows the user to locate and identify the 
document.

Security that will not Interfere with Assistive Technology

Some authors of PDFs restrict users from printing, copying, extracting, editing or adding 
comments to text. The text of an accessible PDF must be available to a screen reader. Acrobat’s 
security settings can be set to protect document content while not interfering with a screen 
reader’s ability to convert the on-screen text to speech or Braille.

Document Structure Tags and Proper Reading Order

To read a document’s text and present it in a way that makes sense to the user, a screen reader 
or other text-to-speech tool requires that the document be structured. Document structure tags 
in a PDF define the reading order and identify headings, paragraphs, sections, tables and other 
page elements. The tags structure also allows for documents to be resized and reflowed for 
viewing at larger sizes and on mobile devices.

Alternative Text Descriptions for Non-Text Elements

Document features such as images and interactive form fields cannot be understood by the 
user of a screen reader unless they have associated alternative text. Though link text is available 
to screen reader users, it is possible to provide more meaningful descriptions via replacement 
(actual) text. Alternative text for images and tooltips can aid many users, including those with 
learning disabilities. Equivalents for multimedia, including any audio and video elements, must 
also be present.

Other Accessible Characteristics

There are additional characteristics of accessible documents including:

•	 No reliance on color or sensory characteristics alone to convey meaning

•	 Use of color combinations that provides a sufficient degree of contrast

•	 Controls for audio
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•	 Use of text instead of images of text

•	 No use of flashing or blinking elements

•	 No focus changes without user initiation

•	 Consistent navigation and identification of elements

Adobe Acrobat and Adobe Reader Accessibility Features

Accessibility features in Adobe Acrobat XI and Adobe Reader XI fall into two broad categories: 
features that make the reading of PDF documents more accessible, and features that help create 
accessible PDF documents. To create accessible PDF documents, you must use Acrobat Pro.

Features to Support the Reading of PDFs by People with Disabilities

All versions of Adobe Acrobat XI, Adobe Reader XI, Acrobat XI Standard and Acrobat XI Pro 
provide support for the accessible reading of PDF files by persons with disabilities:

•	 Preferences and commands to optimize output for assistive technology 
software and devices, such as saving as accessible text for a Braille printer

•	 Preferences and commands to make navigation of PDFs more accessible, 
such as automatic scrolling and opening PDFs to the last page read

•	 An Accessibility Setup Assistant Wizard for easy setting of most 
preferences related to accessibility

•	 Keyboard alternatives to mouse actions

•	 Reflow capability to temporarily present the text of a PDF in a single, 
easy-to-read column

•	 Read Out Loud text-to-speech conversion

•	 Support for screen readers and screen magnifiers

•	 Support for high contrast and alternative foreground and background 
colors

Features to Support the Creation of Accessible PDFs

•	 Creation of tagged PDFs from authoring applications

•	 Conversion of untagged PDFs to tagged PDFs from within Acrobat

•	 Security settings that allow screen readers to access text while preventing 
users from copying, printing, editing and extracting text

•	 Ability to add text to scanned pages to improve accessibility

•	 Tools for editing reading order and document structure

•	 Tools for creating accessible PDF forms

•	 Ability to set document properties including title and expose them 
through the title bar of the application

Though Acrobat Standard provides some functionality for making existing PDFs accessible, 
Acrobat Pro must be used to perform most tasks—such as editing reading order or editing 
document structure tags—that are necessary to make PDF documents and forms accessible 
(“Table 1. Features for Creating Accessible PDF Files by Product” on page 5).



PDF Accessibility Overview

5Adobe® Acrobat® XI Pro Accessibility Guide: Best Practices for PDF Accessibility

Accessibility Features of Adobe XI Reader, Adobe XI Standard, and Adobe 
XI Pro

Table 1.  Features for Creating Accessible PDF Files by Product

Adobe 
Reader XI

Acrobat XI 
Standard

Acrobat XI 
Pro

Create PDF documents from 
any application that prints

• •

Convert Microsoft Word, 
Excel, PowerPoint, Publisher 
and Access files to PDF with 
one-button ease*

• •

Capture web pages from 
Microsoft Internet Explorer 
and Mozilla Firefox as rich, 
dynamic PDF files for review 
and archiving with one-
button ease*

• •

Scan paper documents 
to PDF and automatically 
recognize text with optical 
character recognition (OCR)

• •

Save PDF files as Microsoft 
Word documents, retaining 
the layout, fonts, formatting 
and tables to facilitate reuse 
of content*

• •

Easily create fillable PDF 
forms from paper or existing 
files using the Form Wizard

• •

Enable users of Adobe 
Reader® (version 8 or later) 
to fill in and save PDF forms 
locally

• •

Customize Accessibility 
Preferences with an easy-to-
use wizard

• • •

Set high contrast colors for 
better visibility

• • •

Enable large type display by 
setting text to reflow through 
pages

• • •

Listen to the text in a PDF file 
as it is read aloud

• • •

Make PDF documents more 
accessible by adding tags to 
control reading order and 
improve navigation

•

Specify a reading order for 
pages or columns of text

•

Validate accessible PDF 
documents and check for 
possible accessibility issues

•

-

-

-

-

-

-

-

-

- -

- -

- -
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The Acrobat XI Pro Accessibility Guide Series

Adobe has created a series of accessibility guides for Adobe Acrobat XI Pro to assist content 
authors in creating accessible PDF documents. There are four guides in this series:

PDF Accessibility Overview (this document)

The Adobe® Acrobat® XI Pro Accessibility Guide: PDF Accessibility Overview details what is meant 
by accessibility in the PDF file format. It distinguishes between the accessibility features of the 
file format, of Adobe Acrobat XI and of the Adobe Reader application, and how the features of 
the software and the file format interact to achieve accessibility for people with disabilities.

Acrobat XI Pro PDF Accessibility Repair Workflow

The Adobe® Acrobat® XI Pro Accessibility Guide: PDF Accessibility Repair Workflow provides a step-
by-step method for analyzing existing PDF files and making them accessible based upon that 
analysis. This workflow coincides with the workflow provided in the Make Accessible Action 
wizard and potential issues tested for in the Accessibility Checker tool.

Using the Accessibility Checker in Acrobat XI Pro

The Adobe® Acrobat® XI Pro Accessibility Guide: Using the Accessibility Checker describes the 
PDF accessibility checkers that are included in Adobe Acrobat XI Pro. Even if you generate an 
accessible PDF file from an authoring application such a word processor or desktop publishing 
program, you should then follow the steps in this guide in order to identify any items that may 
have been missed in the initial conversion, or to add PDF accessibility features that were not 
provided by the authoring tool.

Creating Accessible PDF Forms with Acrobat XI Pro

The guide entitled Adobe® Acrobat® XI Pro Accessibility Guide: Creating Accessible Forms describes 
how to use the forms tools within Adobe Acrobat XI Pro to add descriptions to form fields, tag 
untagged forms, set the tab order, manipulate tags and perform other PDF accessibility tasks. 
These techniques do not apply to PDF forms from Adobe LiveCycle Designer, as a separate 
process is provided for making LiveCycle forms accessible.

Acrobat XI Pro Complete Best Practices for Accessibility

The complete content of each individual guide is also available as a single, comprehensive 
document entitled Adobe® Acrobat® XI Pro Accessibility Guide: Best Practices for Accessibility.



Using the Acrobat XI Pro Accessibility Checker
Determine how easily persons with disabilities can access PDF 
documents with the Adobe Acrobat XI Pro Accessibility Checker

The accessibility checking tools in Adobe Acrobat XI Pro—Accessibility Checker (Full Check) and 
the Make Accessible action wizard—can identify many issues in PDF documents that may be in 
conflict with Adobe’s interpretations of the accessibility guidelines referenced in the application 
and its documentation. These tools do not check documents for all accessibility criteria, 
including those in such referenced guidelines, and Adobe does not warrant that documents 
comply with any specific guidelines or regulations.

The Make Accessible Action Wizard

The Make Accessible action wizard walks users through the steps required to make a PDF 
accessible. It prompts to address accessibility issues, such as a missing document description 
such a document title. It looks for common elements that need further action, such as scanned 
text, form fields, tables, and images without alternative text. This action wizard can be run 
on all PDFs except dynamic forms (XFA documents) and portfolios. The last step of the Make 
Accessible action wizard is to run the Acrobat Pro Accessibility Checker (Full Check). For 
complete instructions on how to make documents accessible and repair the accessibility tag 
structure of a document refer to the document titled “Adobe Acrobat XI Pro Accessibility Repair 
Workflow”.

Accessibility Checker (Full Check)

Use the Accessibility Full Check to perform a thorough check for many characteristics of 
accessible PDFs, such as the use of alternative text on images, the presence of tags, document 
language, and fonts that can be mapped reliably to Unicode text.

From the Accessibility Checker dialog, it is possible to choose which kinds of accessibility issues 
to look for. There are also options to view and save the results. To run the Accessibility Full 
Check, perform the following:

1.	 Open the Accessibility Tool pane.

2.	 Select View > Tools > Accessibility from the Adobe Acrobat XI Pro menu. 
(Refer to “Figure 1.  Acrobat XI Pro Accessibility Full Check Tool” on 
page 8.)

3.	 Select Full Check from the Accessibility tools.

4.	 The Accessibility Checker Options dialog appears (Refer to “Figure 2.  
Acrobat XI Pro Accessibility Checker Options Dialog” on page 8).

5.	 Set Report Options.

6.	 You can save the results as an HTML file or attach the report to the 
document.

7.	 Select a page range if you prefer to perform a check on individual sections 
of a document.

8.	 Select checking options.

Using the Acrobat XI Pro Accessibility Checker
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9.	 Choose a category from the dropdown, and then select the accessibility 
options to check for. By default, everything but “tables must have a 
summary” is checked.

10.	You can select Document; Page Content; Forms, Tables and Lists; and 
Alternate Text and Headings to reveal checkboxes that let you set the 
level of testing that you want Acrobat to perform.

11.	Activate the Start Checking button.

Figure 1.   Acrobat XI Pro Accessibility Full Check Tool

Figure 2.   Acrobat XI Pro Accessibility Checker Options Dialog

Figure 3.  After the check is complete, the results are displayed via the Accessibility Checker 
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panel. (See “Figure 4. Acrobat Xi Pro Accessibility Checker Panel” on page 9)

Figure 4.  Acrobat Xi Pro Accessibility Checker Panel

If a report was checked to be created in the Accessibility Checker Options dialog, the results are 
available in the selected folder or an attachment. (See “Figure 5.  Acrobat XI Pro Accessibility 
Report” on page 10) The Accessibility Report can also be displayed by activating the 
Accessibility Report tool command in the Accessibility tools pane.
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Figure 5.   Acrobat XI Pro Accessibility Report

The Accessibility Full Check feature is unable to distinguish the intention of the document 
author such as whether a figure is purely decorative, so some issues it reports may not affect 
the functional accessibility of the document. Manual review of the issues may be required to 
determine whether to fix or ignore the issue.

Accessibility Checker Options

The Accessibility Checker (Full Check) has the following options that can be selected:

•	 Document

•	 	Accessibility permission flag is set

•	 	Document is not image-only PDF

•	 	Document is tagged PDF

•	 	Document structure provides a logical reading order

•	 	Text language is specified

•	 	Document title is showing in title bar

•	 	Bookmarks are present in large documents

•	 	Document has appropriate color contrast

•	 Page Content

•	 	All page content is tagged

•	 	All annotations are tagged

•	 	Tab order is consistent with structure order

•	 	Reliable character encoding is provided

•	 	All multimedia objects are tagged

•	 	Page will not cause screen to flicker

•	 	No inaccessible scripts

•	 	Navigation links are not repetitive

•	 	Page does not require timed responses
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•	 Forms, Tables and Lists

•	 	All form fields are tagged

•	 	All form fields have description

•	 	TR must be a child of Table, THead, TBody, or TFoot

•	 	TH and TD must be children of TR

•	 	Tables must have headers

•	 	Tables must contain the same number of columns in each row and 
rows in each column

•	 	Tables must have a summary

•	 	LI must be a child of L

•	 	Lbl and LBody must be children of LI

•	 Alternate Text and Headings

•	 	Figures require alternate text

•	 	Alternate text that will never be read

•	 	Alternate text must be associated with some content

•	 	Alternate text should not hide annotation

•	 	Elements require alternate text

•	 	Appropriate heading nesting

Accessibility Checker Panel

Once a report has been run, the issues that have been found are displayed in the Accessibility 
Checker panel. The results tree displays one of the following states for each rule check (See 
“Figure 6. Acrobat Rule Check States” on page 12):

•	 Passed: The item passed this accessible check.

•	 Passed Manually: The item was marked passed by manual inspect.

•	 Skipped By User: The rule was not selected in the Accessibility Checker 
Options dialog box.

•	 Needs Manual Check: The Full Check feature could not check the item 
automatically. Verify the item manually.

•	 Failed: The item did not pass the accessibility check.
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Figure 6.  Acrobat Rule Check States

To fix a failed check after running Accessibility Full Check, activate the context menu—right-click 
(Windows) or Control-click (Mac OS) the item in the Accessibility Checker panel. Choose one 
of the following options from the context menu (See “Figure 7. Accessibility Checker Panel 
Showing Issue States for each Checker Option” on page 13):

•	 Fix: Acrobat either fixes the item automatically, or displays a dialog box 
prompting the user to fix the item by entering information or making 
a choice. For example, a dialog is displayed allowing the user to enter 
alternative text for an image.

•	 Skip Rule: Deselects this option in the Accessibility Checker Options 
dialog box for future checks of this document, and changes the item 
status to Skipped.

•	 Explain: Opens the online Help.

•	 Check Again: Runs the checker again on all items. Choose this option 
after modifying one or more items.

•	 Show Report: Displays the accessibility report for the page range/
document with links to tips on how to repair failed checks. The link to tips 
is the same as the help that is provided by the “explain” item. Once the 
report is shown, a new option to attach the report also appears.

•	 Options: Opens the Accessibility Checker Options dialog box where 
checking options can be set.
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Figure 7.  Accessibility Checker Panel Showing Issue States for each Checker Option

Accessibility Checker Option Details

This section provides information on each option in the Accessibility Checker. Please refer to the 
“Adobe Acrobat XI Pro Accessibility Repair Workflow” document for details on how to address 
issues for each category.

Documentation Category

Accessibility permission flag: A document author can specify that no part of an accessible PDF 
is to be copied, printed, extracted, commented on, or edited. This setting can interfere with the 
user of a screen reader’s ability to read the documents screen readers must be able to copy or 
extract the document’s text to convert it to speech.

This flag reports whether it’s necessary to turn on the security settings that allow accessibility.

To fix the rule automatically, select Accessibility Permission Flag on the Accessibility Checker 
panel. Then, choose Fix from the Options menu.

Note: 	 Refer to the related WCAG section: 1.1.1 Non-text Content. (A), 4.1.2 Name, role, 
value

Image-only PDF: Reports whether the document contains non-text content that is not 
accessible. If the document appears to contain text, but doesn’t contain fonts, it could be an 
image-only PDF file.

To fix this item automatically, select Image-only PDF on the Accessibility Checker panel, and 
choose Fix from the Options menu. This will open the “Recognize Text - General Settings” dialog 
and then perform optical character recognition (OCR) on the document.

Note: 	 See the related WCAG section: 1.1.1. Non-text content (A)
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Tagged PDF: If this rule check fails, the document is not tagged to specify the correct reading 
order for reflow and assistive technology. Documents without tags also do not provide 
information describing the logical structure and relationship of elements to users of assistive 
technology.

To fix this item automatically, select Tagged PDF on the Accessibility Checker panel, and then 
choose Fix from the Options menu. Acrobat automatically adds tags to the PDF. The tags that 
were added still must be reviewed to ensure they are correct.

Note: 	 Refer to the related WCAG section: 1.3.1 Info and Relationships, 1.3.2 Meaningful 
Sequence, 2.4.1 Bypass Blocks, 2.4.4 Link Purpose, 2.4.5 Multiple Ways, 2.4.6 
Headings and labels, 3.1.2 Language of Parts, 4.1.2 Name, role, value

Logical reading order: Verify this rule check manually. Make sure that the reading order 
displayed in the Tags panel reflects the logical reading order of the document.

Primary language: Setting the document language in a PDF enables some screen readers to 
switch to the appropriate language. This check determines whether the primary text language 
for the PDF is specified. If the check fails, set the language.

To set the language automatically, select Primary Language in the Accessibility Checker tab, and 
then choose Fix from the Options menu. Choose a language in the Set Reading Language dialog 
box, and then click OK. This does not set the language for specific parts of the document that 
may be in different languages. To set specific portions of the document in different languages 
refer to the Adobe Acrobat XI Pro Accessibility Repair Workflow guide.

Note: 	 See the related WCAG section: Language of Page (Level A)

Title: Reports whether there is a document title. Document authors can choose to have the title 
appear in the Acrobat or Adobe Reader application title bar rather than the document file name.

To fix the title automatically, select Title in the Accessibility Checker tab, and choose Properties 
from the Options menu. Enter the document title in the Description dialog box (deselect Leave 
As Is, if necessary).

Note: 	 See the related WCAG section: 2.4 Page Titled (Level A)

Bookmarks: This check fails when the document has 21 or more pages, but does not have 
bookmarks that parallel the document structure.

To add bookmarks to the document, select Bookmarks on the Accessibility Checker panel, and 
choose Fix from the Options menu. In the Structure Elements dialog box, select the element(s) 
that you want to use as bookmarks, and click OK (See “Figure 8. Fix missing bookmarks in 
Acrobat” on page 15). You can also access the Structure Elements dialog box by clicking the 
Options menu on the Bookmark tab.

Note: 	 See the related WCAG sections: 2.4.1 Bypass Blocks (Level A), 2.4.5 Multiple 
Ways (Level AA)
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Figure 8.  Fix missing bookmarks in Acrobat

Color contrast: When this check fails, it’s possible that the document contains content that is 
not accessible to people who have low vision or color deficiencies.

To fix this issue, make sure that the document’s content adheres to the guidelines outlined in 
WCAG section 1.4.3 or include a recommendation that the PDF viewer use high-contrast colors 
and verify that all content is readable in the high-contrast color scheme:

To check the document in a high contrast color scheme perform the following:

1.	 Choose Edit > Preferences (Windows) or Acrobat > Preferences (Mac OS).

2.	 Choose the Accessibility category.

3.	 Select Replace Document Colors, and then select Use High-Contrast 
Colors. Choose the color combination that you want from the pop-
up menu, and then click OK (See “Figure 9. Adjust viewer to display 
document with high contrast settings” on page 16).
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Figure 9.  Adjust viewer to display document with high contrast settings

Page content

Tagged content: This check reports whether all content in the document is tagged. Make sure 
that all content in the document is either included in the Tags tree, or if decorative marked as an 
artifact.

Perform one of the following to fix this check:

•	 If the content is purely decorative, set it as an artifact.

•	 Use the Touch Up Reading Order tool to tag the content.

•	 Use the Tag panel to tag the content.

Please refer to the Adobe Acrobat XI Pro Accessibility Repair Workflow Guide for instructions on 
how to tag content.

Note: 	 See the related WCAG sections: 1.1.1 Non-text content (A), 1.3.1 Info and 
Relationships (Level A), 1.3.2 Meaningful Sequence (Level A), 4.1.2 Name, role, 
value

Tagged annotations: This option checks whether all annotations are tagged. Make sure that 
annotations such as comments and editorial marks (such as insert and highlight) are either 
included in the Tags tree if meaningful, or marked as artifacts if they’re purely decorative or 
duplicated in the content.

•	 If the content is purely decorative, set it as an artifact.

•	 Use the Tag Panel and the Find command to search for and tag the 
content as an annotation.

Please refer to the Adobe Acrobat XI Pro Accessibility Repair Workflow Guide for instructions on 
how to tag annotations.

To have Acrobat assign tags automatically to annotations as they’re created, choose Tag 
Annotations from the Options menu on the Tags panel. This is the easiest approach to tag 
annotations that have not already been created, as the annotation tags will appear in the correct 
location in the reading order of a properly tagged document.
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Note: 	 See the related WCAG section: 1.3.1 Info and Relationships (Level A), 4.1.2 Name, 
role, value

Tab order: Because the Tab key is often used to navigate links, annotations, and form fields in a 
PDF, it’s necessary that the tab order parallels the document structure.

To fix the tab order automatically, select Tab Order on the Accessibility Checker panel, and 
choose Fix from the Options menu. This will specify the tab order to follow the document 
structure.

Note: 	 See the related WCAG section: 2.4.3, Focus Order (Level A)

Character encoding: Specifying the encoding helps PDF viewers present users with readable 
text. However, some character-encoding issues are not repairable within Acrobat.

To ensure proper encoding, do the following:

•	 Verify that the necessary fonts are installed on your system.

•	 Use a different font (preferably OpenType) in the original document, and 
then re-create the PDF.

•	 Re-create the PDF file with a newer version of Acrobat Distiller.

•	 Use the latest Adobe PostScript driver to create the PostScript file, and 
then re-create the PDF.

Note: 	 The WCAG does not directly address Unicode character mapping.

Tagged multimedia: This rule checks whether all multimedia objects are tagged. Make sure that 
content is either included in the Tags tree or, if decorative or duplicative, marked as an artifact.

Perform one of the following to fix this check:

•	 If the content is purely decorative, set it as an artifact.

•	 Use the Touch Up Reading Order tool to tag the content.

•	 Use the Tag panel to tag the content.

Please refer to the Adobe Acrobat XI Pro Accessibility Repair Workflow Guide for instructions on 
how to tag content.

In addition to providing tags and description of all multimedia, captions (for people who are 
deaf or hard of hearing) or audio descriptions (for people who are blind or visually impaired)
may need to be synchronized with the multimedia. Please refer to the relevant guideline or 
standard for multimedia requirements.

Note: 	 See the related WCAG sections: 1.1.1 Non-text Content. (A), 1.2.1 Audio- only 
and Video- only (Prerecorded). (A), 1.2.2 Captions (Prerecorded). (A), 1.2.3 Audio 
Description or Media Alternative (Prerecorded). (A), 1.2.5 Audio Description 
(Prerecorded). (AA)
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Screen flicker: Elements that make the screen flicker, such as animations and scripts can cause 
seizures in individuals who have photosensitive epilepsy. These elements can also cause 
difficulty for users with low vision and people with cognitive disabilities.

If the Screen Flicker rule fails, manually remove or modify the script or content that causes 
screen flicker.

Note: 	 See these related WCAG sections: 2.3.1 Three Flashes or Below Threshold. (Level 
A)

Scripts: Content cannot be script-dependent unless both content and functionality are 
accessible with the keyboard and to assistive technologies. Make sure that scripting does not 
interfere with keyboard navigation or prevent the use of any input device.

Check the scripts manually. Remove or modify any script or content that compromises 
accessibility.

Note: 	 See these related WCAG sections: 1.1.1 Non-text Content. (A), 2.1.1 Keyboard 
(Level A), 2.2.2 Pause, Stop, Hide. (Level A), 4.1.2 Name, role, value

Timed responses: This check applies to documents that contain forms with JavaScript. If the rule 
check fails, make sure that the page does not require timed responses. Edit or remove scripts 
that impose timely user responses so that users have enough time to read and use the content.

Note: 	 See the related WCAG section: 2.2.1 Timing Adjustable. (Level A)

Navigation links: For URLs to be accessible to screen readers, they must be active links that 
are correctly tagged in the PDF document and keyboard accessible. (The best way to create 
accessible links is with the Create Link command, which adds link objects that screen readers 
require to recognize a link.) Use the Tags panel’s Find command to properly tag Links that are 
not accessible.

Link text must also be understandable on its own without surrounding content. If this rule check 
fails, check navigation links manually and verify that the content does not have links with an 
identical name but different target locations. Either change the link text or add actual text to the 
link tag to provide additional description out of context for users of screen readers.

Documents must also provide a way for users to skip over items that appear multiple times. 
For example, if the same links appear on each page of the document, also include a bookmark 
element to skip past the repetitive link group to the next tagged element in the structure . Links 
can not be used to skip past repetitive links as links can not focus tags in the tree and only scroll 
or zoom to a particular page view.

Note: 	 See the related WCAG section: 2.4.1 Bypass Blocks (Level A), 2.1.1 Keyboard 
(Level A), 2.4.4 Link Purpose (In Context) (Level A).

Forms

Tagged form fields: All form fields must be tagged with a form tag and form object element and 
part of the document structure. In addition, field descriptions (labels) must be provided via the 
tooltip form field property to provide the user with a label or instructions for a field.
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To tag form fields, choose Tools > Accessibility > Add Tags To Form Fields. This add the tags and 
form object elements to the form fields in the proper location in the Tags panel. This step does 
not add field descriptions.

Note: 	 See the related WCAG sections: 1.3.1 Info and Relationships. (Level A), 4.1.2 
Name, role, value

Field descriptions: All form fields must have a text label/description (this is set via the form 
field’s tooltip property).

To add a text description to a form field, use the form tools. Please refer to the “Adobe Acrobat 
XI Pro Accessibility Form Guide” document for complete instructions on how to set form field 
descriptions. Accessibility guidelines and standards may also require that visual labels be 
present. The tooltip property is only visible via the mouse and not the keyboard, thus, on-
screen labels should also be provided for all user input.

Note: 	 See the related WCAG sections: 1.3.1 Info and Relationships. (Level A), 3.3.2 
Labels or Instructions (Level A), 4.1.2 Name, role, value

Alternate Text

Figures alternate text: Make sure that images in the document either have alternate text or, if 
decorative, are marked as artifacts.

If this check fails, perform one of the following:

•	 Select Figures Alternate Text in the Accessibility Checker panel, and 
choose Fix from the Options menu (or context menu). Add alternate text 
as prompted in the Set Alternate Text dialog box (See “Figure 10. Set 
Alternate Text through the Fix option in the Accessibility Checker” on 
page 20).

•	 Use the Tags panel to add alternate text for images in the PDF.

•	 Use the Tags panel, Content Panel, or Touch Up Reading Order tool to 
make the content an artifact.

Note: 	 See the related WCAG section: 1.1.1 Non-text Content. (A)
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Figure 10.  Set Alternate Text through the Fix option in the Accessibility Checker

Nested alternate text/actual text:

Screen readers do not read the alternate/actual text for nested elements. Therefore, do not 
apply alternate text to elements with children unless the alternative text or actual text covers the 
content for these elements as well. Alternative text is used to provide an alternative for images 
(figures). Actual text is used to provide an alternative to text content.

Remove alternate/actual text from nested elements via the Tags panel. For more information 
on using alternative text and actual text refer to the Adobe Acrobat XI Pro Accessibility Repair 
Workflow Guide.

Refer to the related WCAG success criteria: 1.1.1 Non-text Content (Level A).

Associated with content: Make sure that alternate text is always an alternate representation for 
content on the page. If an element has alternate text, but does not contain any page content, 
there is no way to determine which page it is on. If the Screen Reader Option in the Reading 
preferences is not set to read the entire document, then screen readers never read the alternate 
text.

To fix this issue, assign page content to the tag that contains the alternative/actual text.

Note: 	 See the related WCAG section: 1.1.1 Non-text Content. (A)

Hides annotation: Alternate text can not hide an annotation. If an annotation is nested under a 
parent element with alternate/actual text, then a screen reader will not announce it.

Remove alternate/actual text from parent element. If alternate/actual text is needed make 
sibling objects out of content and the annotation and assign the actual/alternate text to the 
sibling tag. For more information on using alternate text and actual text, refer to the Adobe 
Acrobat XI Pro Accessibility Repair Workflow Guide.

See the related WCAG sections: 1.3.1 Info and Relationships. (Level A), 4.1.2 Name, role, value

Other elements alternate text: This option checks for content other than figures that requires 
alternate text such as multimedia, annotation, or 3D models. Make sure that alternate text is 
always an alternate representation for content on the page. If an element has alternate text 
but does not contain any page content, there is no way to determine which page it is on. If the 
Screen Reader Options in the Reading preferences is not set to read the entire document, then 
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screen readers won’t read the alternate text. If additional description is required for the object 
beyond what can be provided in alternative text, provide a on-page description or link to a 
description of the non-text object.

Note: 	 See the related WCAG section: 1.1.1 Non-text Content. (A)

Tables

Because table structure can be complex, it is best practice to check them for accessibility 
manually.

Rows: This check indicates whether each TR in a table is a child of Table, THead, TBody, or 
TFoot.

To fix this issue ensure that any TR tags are a child of a Table, THead, TBody, or TFoot tag.

Note: 	 Related WCAG section: 1.3.1 Info and Relationships. (Level A)

TH and TD: This check indicates whether a proper table structure exists. TH and TD must be 
children of a TR element; if not this check fails.

To fix this issue, ensure that TH or TD tags are place under a TR tag.

Note: 	 See related WCAG section: 1.3.1 Info and Relationships (Level A)

Headers: For accessibility, it’s necessary that all tables in the PDF have a header.

To fix this issue, ensure that all tables contain table header cells.

Note: 	 See the related WCAG section: 1.3.1 Info and Relationships (Level A)

Regularity: To be accessible, tables must contain the same number of columns in each row, and 
rows in each column.

To fix this issue, ensure that each table row has the same number of columns or the ColSpan and 
RowSpan properties of a cell are set properly to account for all cells in a row.

Note: 	 See the related WCAG section: 1.3.1 Info and Relationships (Level A)

Summary: Table summaries are optional unless the table data cannot be understood without it. 
Summaries can improve accessibility in complex data tables or when the way in which the data 
is read may be important.

To fix this issue, provide a table summary for data tables where it is needed to make the data 
easier to understand, or to provide instructions on the data should be reviewed.

Note: 	 See the related WCAG section: 1.3.1 Info and Relationships. (Level A)



Using the Acrobat XI Pro Accessibility Checker

22Adobe® Acrobat® XI Pro Accessibility Guide: Best Practices for PDF Accessibility

Lists

List items: This check reports whether each LI is a child of L tag. When this check fails, the 
structure of this list is incorrect. Lists must have the following structure: a List element must 
contain List Item elements; List Item elements can only contain Label elements and List Item 
Body elements.

To fix this issue, ensure that all list item elements have a parent L tag.

Note: 	 See the related WCAG section: 1.3.1 Info and Relationships. (Level A)

Lbl and LBody: Lists must have the following structure: a List element must contain List Item 
elements; List Item elements can only contain Label elements and List Item Body elements. 
When this check fails, the structure of this list is incorrect.

To fix the list structure, use the Tags panel to place Lbl and LBody elements under each list item. 
The list bullet or number should be a text node of the Lbl tag and the list item text a text node 
of the LBody tag.

Note: 	 Refer to the related WCAG success criteria: 1.3.1 Info and Relationships (Level 
A)

Headings

Appropriate nesting: This rule checks nested headings. When this check fails, headings are 
not nested properly. For example, a level 1 heading should precede a level 2 heading, etc. The 
Accessibility Checker is not able to determine when heading structures must be used—that 
must be determined by manually reviewing the document.

To fix this issue, ensure that all heading levels are nested accordingly with no missing heading 
levels. Use the Tags Panel or Touch Up Reading Order tool to assign heading tags.

Refer the related WCAG section: 1.3.1 Information and Relationships. (Level A). The order of 
headings is not required under WCAG, and is only an advisory technique.

Continue Checking Until All Issues are Addressed

Repeat the process of running the Accessibility Checker and associated repair techniques along 
with the Hints for Repair until the Accessibility Checker indicates “Passed” for all selected tests 
(See “Figure 11. A Successful Accessibility Check” on page 23).

Note: 	 While the Accessibility Checker helps evaluate the accessibility of a document 
and helps identify areas that may be in conflict with Adobe’s interpretations 
of the referenced guidelines, the Accessibility Checker can not automatically 
check all accessibility guidelines and criteria, including those in such referenced 
guidelines, and Adobe does not warrant that any documents will comply with 
any specific guidelines or regulations. Please consult with appropriate legal 
counsel for guidance on compliance with the referenced guidelines or any other 
accessibility guidelines.
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Figure 11.  A Successful Accessibility Check

Additional Functional Validation Techniques
The Accessibility Checker can evaluate many of the technical requirements for accessibility. The 
best way to test the functional accessibility of a document is to use the document with the same 
tools that readers will use. It is recommended to review the document with assistive technology 
including a screen reader. Even when a screen reader is not available, the following methods 
provided by Acrobat should be used to check the accessibility of a PDF file:

Use Reflow view to quickly check reading order:

1.	 Activate the View > Zoom > Zoom Text.

2.	 Enter 200 in the zoom field.

3.	 Activate the View > Zoom.

4.	 Activate The reflow option.

5.	 Verify that all content appears in the correct order.

6.	 Verify that all content is readable while zoomed.

Use Read Out Loud to experience the document as it will be heard by readers who use this 
text-to-speech tool.

1.	 Activate > View > Read Out Loud > Activate Read Out Loud

2.	 Activate > View > Read Out Loud > Read this page only

3.	 Verify that all page content is announced in the correct order.
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4.	 Repeat for each page.

Save the document as accessible text and then read the saved text file in a word-processing 
application to experience the document as it will be read by readers who may emboss the 
document in Braille.

1.	 Activate File > Save as > Text Plain (.txt)

2.	 Select the desired location.

3.	 Activate the Save button.

WCAG 2.0 Mapng to PDF/UA
The table below provides a mapping between WCAG 2.0 success criteria, the PDF/UA standard 
(ISO 14289-1) and PDF techniques for WCAG 2.0.

WCAG 2.0  	 ISO 14289 -1 (File)  	 Techniques
1.1.1 Non-text Content. (A) •	 7.3 addresses content 

requiring text alteration.

•	 7.18.1 paragraph 4 
addresses control 
descriptions.

•	 7.18.6.2 addresses time-
based media alternatives. 
Test, Sensory, and 
CAPTCHA use cases are 
addressed via the technical 
means used.

•	 7.1 paragraph 1, sentence 2 
addresses decoration.

•	 PDF1

•	 PDF4

1.2.1 Audio- only and Video- 
only (Prerecorded). (A)

•	 7.18.6.2 addresses time-
based media alternatives. 
Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
media-equiv-av-only-alt

1.2.2 Captions (Prerecorded). 
(A)

•	 7.18.6.2 addresses time-
based media alternatives. 
Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
media-equiv-captions

http://www.w3.org/TR/WCAG20-TECHS/PDF1.html
http://www.w3.org/TR/WCAG20-TECHS/PDF4.html
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-av-only-alt
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-av-only-alt
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-av-only-alt
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-captions
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-captions
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-captions
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WCAG 2.0  	 ISO 14289 -1 (File)  	 Techniques
1.2.3 Audio Description 
or Media Alternative 
(Prerecorded). (A)

•	 7.18.6.2 addresses time-
based media alternatives. 
Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
media-equiv-audio-desc

1.2.4 Captions (Live). (AA) •	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
media-equiv-real-time-
captions

1.2.5 Audio Description 
(Prerecorded). (AA)

•	 7.18.6.2 addresses time-
based media alternatives. 
Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
media-equiv-audio-desc-
only

1.2.6 Sign Language 
(Prerecorded). (AAA)

•	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

1.2.7 Extended Audio 
Description (Prerecorded). 
(AAA)

•	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance

1.2.8 Media Alternative 
(Prerecorded). (AAA)

•	 7.18.6.2 addresses time-
based media alternatives. 
Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

1.2.9 Audio- only (Live). 
(AAA)

•	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

1.3.1 Info and Relationships. (Level 
A)

•	 7.1 - 7.10 and 7.20 address 
structure and relationships 
in content.

•	 7.17 and 7.18 address 
structure and relationships 
in annotations.

•	 PDF6

•	 PDF9

•	 PDF10

•	 PDF11

•	 PDF12

•	 PDF17

•	 PDF20

•	 PDF21

http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-real-time-captions
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-real-time-captions
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-real-time-captions
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-real-time-captions
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc-only
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc-only
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc-only
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc-only
http://www.w3.org/TR/WCAG20-TECHS/PDF6.html
http://www.w3.org/TR/WCAG20-TECHS/PDF9.html
http://www.w3.org/TR/WCAG20-TECHS/PDF10.html
http://www.w3.org/TR/WCAG20-TECHS/PDF11.html
http://www.w3.org/TR/WCAG20-TECHS/PDF12.html
http://www.w3.org/TR/WCAG20-TECHS/PDF17.html
http://www.w3.org/TR/WCAG20-TECHS/PDF20.html
http://www.w3.org/TR/WCAG20-TECHS/PDF21.html
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WCAG 2.0  	 ISO 14289 -1 (File)  	 Techniques
1.3.2 Meaningful Sequence. 
(Level A)

•	 7.2 paragraph two 
addresses the meaningful 
sequence of content.

•	 7.17 addresses navigation 
features.

•	 7.18.3 addresses tab order 
in annotations.

•	 PDF3

1.3.3 Sensory Characteristics. 
(Level A)

•	 7.1, paragraphs 6 and 7 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
content-structure-
separation-understanding

1.4.1 Use of Color. (Level A) •	 7.1, paragraph 6 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
visual-audio-contrast-
without-color

1.4.2 Audio Control. (Level A) •	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
visual-audio-contrast-dis-
audio

1.4.3 Contrast (Minimum). 
(Level AA)

•	 7.1, paragraph 6 and note 4 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
visual-audio-contrast-
contrast

1.4.4 Resize text. (Level AA) •	 Not applicable •	 G142

1.4.5 Images of Text. (Level 
AA)

•	 7.3, paragraph 6 •	 PDF7

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
visual-audio-contrast-text-
presentation

1.4.6 Contrast (Enhanced). 
(Level AAA)

•	 7.1, paragraph 6

1.4.7 Low or No Background 
Audio. (Level AAA)

•	 While ISO 14289 does 
not address this success 
criterion, conformance in 
PDF requires ISO 14289 
conforming files and 
readers. The manner in 
which developers support 
this success criterion in 
PDF in not defined in ISO 
14289 or ISO 32000.

1.4.8 Visual Presentation. 
(Level AAA)

•	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

http://www.w3.org/TR/WCAG20-TECHS/PDF3.html
http://www.w3.org/WAI/WCAG20/quickref/#qr-content-structure-separation-understanding
http://www.w3.org/WAI/WCAG20/quickref/#qr-content-structure-separation-understanding
http://www.w3.org/WAI/WCAG20/quickref/#qr-content-structure-separation-understanding
http://www.w3.org/WAI/WCAG20/quickref/#qr-content-structure-separation-understanding
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-without-color
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WCAG 2.0  	 ISO 14289 -1 (File)  	 Techniques
1.4.9 Images of Text (No 
Exception). (Level AAA)

•	 7.3 paragraph 1

2.1.1 Keyboard. (Level A) •	 Not applicable •	 PDF3

•	 PDF11

•	 PDF23

2.1.2 No Keyboard Trap. 
(Level A)

•	 Design-specific. It’s 
necessary that developers 
consider this provision and 
ensure conformance.

•	 G21

2.1.3 Keyboard (No 
Exception). (Level AAA)

•	 7.19, paragraph 3

2.2.1 Timing Adjustable. 
(Level A)

•	 7.19, paragraph three 
applies, but generally this 
rule is design-specific. It’s 
necessary that developers 
consider this provision and 
ensure conformance.

•	 G133

2.2.2 Pause, Stop, Hide. (Level 
A)

•	 7.19 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
time-limits-pause

2.2.3 No Timing. (Level AAA) •	 7.19

2.2.4 Interruptions. (Level 
AAA)

•	 7.19

2.2.5 Re- authenticating. 
(Level AAA)

•	 Not applicable

2.3.1 Three Flashes or Below 
Threshold. (Level A)

•	 7.1, paragraph 5 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
seizure-does-not-violate

2.3.2 Three Flashes.(Level 
AAA)

•	 7.1, paragraph 5

2.4.1 Bypass Blocks. (Level A) •	 Not applicable, unless the 
PDF includes repetitive 
real content. Page content, 
such as running headers 
and footers, must conform 
with 7.8.

•	 PDF9

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
navigation-mechanisms-
skip

2.4.2 Page Titled. (Level A) •	 7.1, paragraphs 8 and 9 •	 PDF18

2.4.3 Focus Order. (Level A) •	 7.1, paragraph 2, 7.18.1; 
paragraph 2, 7.18.3

•	 PDF3

2.4.4 Link Purpose (In 
Context). (Level A)

•	 7.18.5 •	 PDF11

•	 PDF13

http://www.w3.org/TR/WCAG20-TECHS/PDF3.html
http://www.w3.org/TR/WCAG20-TECHS/PDF11.html
http://www.w3.org/TR/WCAG20-TECHS/PDF23.html
http://www.w3.org/TR/2012/NOTE-WCAG20-TECHS-20120103/G21
http://www.w3.org/TR/WCAG20-TECHS/G133.html
http://www.w3.org/WAI/WCAG20/quickref/#qr-seizure-does-not-violate
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http://www.w3.org/TR/WCAG20-TECHS/PDF9.html
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http://www.w3.org/TR/WCAG20-TECHS/PDF18.html
http://www.w3.org/TR/WCAG20-TECHS/PDF3.html
http://www.w3.org/TR/WCAG20-TECHS/PDF11.html
http://www.w3.org/TR/WCAG20-TECHS/PDF13.html
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WCAG 2.0  	 ISO 14289 -1 (File)  	 Techniques
2.4.5 Multiple Ways. (Level 
AA)

•	 PDFs can conform with this 
provision in several ways, 
including outlines (7.17), 
links (7.18.5), and page 
labels.

•	 PDF2

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
navigation-mechanisms-
mult-loc

2.4.6 Headings and Labels. 
(Level AA)

•	 7.4 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
navigation-mechanisms-
descriptive

2.4.7 Focus Visible. (Level AA) •	 Not applicable •	 G149

•	 G165

•	 G195

2.4.8 Location. (Level AAA) •	 7.4, 7.17

2.4.9 Link Purpose (Link 
Only). (Level AAA)

•	 7.18.5

2.4.10 Section Headings. 
(Level AAA)

•	 7.4

3.1.1 Language of Page. (Level 
A)

•	 7.2, paragraph 3. •	 PDF16

•	 PDF19

3.1.2 Language of Parts. 
(Level AA)

•	 7.2, paragraph 3. •	 PDF19

3.1.3 Unusual Words. (Level 
AAA)

•	 Not addressed in ISO 
14289. See ISO 32000-1, 
section 14.9.5.

3.1.4 Abbreviations. (Level 
AAA)

•	 Not addressed in ISO 
14289. See ISO 32000-1, 
section 14.9.5.

3.1.5 Reading Level. (Level 
AAA)

•	 No Accessibility Support 
impact. This rule is design-
specific. It’s necessary that 
application or document 
authors consider this 
provision and ensure 
conformance.

3.1.6 Pronunciation. (Level 
AAA)

•	 PDF provides several 
mechanisms for deploying 
media and other options 
for pronunciation 
assistance. Design-specific. 
It’s necessary that authors 
and developers consider 
this provision and ensure 
conformance.

http://www.w3.org/TR/WCAG20-TECHS/PDF2.html
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-mult-loc
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http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-mult-loc
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http://www.w3.org/TR/WCAG20-TECHS/PDF19.html
http://www.w3.org/TR/WCAG20-TECHS/PDF19.html
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WCAG 2.0  	 ISO 14289 -1 (File)  	 Techniques
3.2.1 On Focus. (Level A) •	 7.18, paragraph 2 •	 General Techniques: 

http://www.w3.org/WAI/
WCAG20/quickref/#qr-
consistent-behavior-
receive-focus

3.2.2 On Input. (Level A) •	 7.18, paragraph 2 •	 PDF15

3.2.3 Consistent Navigation. 
(Level AA)

•	 7.1, paragraph 1, 7.17 •	 PDF14

•	 PDF17

•	 G61

3.2.4 Consistent Identification. 
(Level AA)

•	 7.1, paragraph 1 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
consistent-behavior-
consistent-functionality

3.2.5 Change on Request. 
(Level AAA)

•	 7.19, paragraph 2

3.3.1 Error Identification. 
(Level A)

•	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 PDF5

•	 PDF22

3.3.2 Labels or Instructions 
(Level A)

6.2 •	 PDF5

•	 PDF10

4.1.2 Name, role, value 7.18 •	 PDF10

•	 PDF12

http://www.w3.org/WAI/WCAG20/quickref/#qr-consistent-behavior-receive-focus
http://www.w3.org/WAI/WCAG20/quickref/#qr-consistent-behavior-receive-focus
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This document describes the process for making PDF documents accessible. Whenever possible, 
accessibility should be incorporated directly into the document using the application that 
created it. When accessibility is incorporated directly into the source document, less repair work 
will be required in Adobe Acrobat. This is very important when the PDF must be regenerated 
based on changes in the source file. If changes are only made in the PDF and not in the source 
file, accessibility work will need to be done each time the document is updated.

Adobe Acrobat XI Pro contains a Make Accessible Wizard that guides the user through the basic 
steps found in this document. This tutorial can be used with or without the wizard.

The process of making existing PDF files accessible consists of a few basic steps:

1.	 Examine the PDF document (See “Step 1: Examine the PDF File” on page 
31).

2.	 Add document properties and interactive features to the PDF such as links 
and bookmarks and set the document open settings and security so that 
it does not interfere with assistive technology (See “Step 2: Add Document 
Properties and Interactive Features” on page 31).

3.	 Determine if the PDF originated from a scan. If so, perform Optical 
Character Recognition (OCR) using the OCR Text Recognition command 
in Adobe Acrobat XI (See “Step 3: Perform OCR on Scanned Document” on 
page 37) .

4.	 If the PDF is intended to be an interactive document, add fillable form 
fields and buttons with labels and accessible names. Set the tab order for 
the form fields, provide instructions, ensure proper keyboard focus, and 
ensure any error handling is accessible (See “Step 4: Add Form Fields and 
Set the Tab Order” on page 41) . If the PDF document does not have 
interactive form fields and buttons, then skip to Step 5.

5.	 Set the document’s language.

6.	 Add tags to the PDF file if it has not been tagged. Tagging should be 
performed at this step in the workflow to ensure that any elements that 
were added during steps 1 through 4 are included in the document’s 
structure. (See “Step 6: Add Tags to the Document” on page 42).

7.	 Determine if the PDF file has been properly tagged. Verify tagged 
elements are properly sequenced and applied. For example, is a first-level 
heading tagged as an H1 and not an H3? (See “Step 7: Examine and Repair 
the Tag Structure” on page 52). 

8.	 Add Alternative Text. Add informative and concise alternative text and 
descriptions for all non-text elements. 

9.	 Check the document with the Acrobat Accessibility Checker. Refer 
to the results of the Accessibility Checker and Report and use the 
recommendations to make any necessary changes. Repeat this process 

Acrobat XI Pro PDF Accessibility Repair Workflow
Analyze PDF files and add enhancements to make  
documents accessible to all users
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until the checker indicates no problems are found in the document (See 
“Step 9: Use the Accessibility Checker to Evaluate the PDF File” on page 
78).

Note: 	 These steps are presented in an order that suits most needs most of the time. It may 
be necessary to perform them in a different order for a particular workflow. You may 
need to repeat some steps to achieve the desired result. In all cases, examine the 
document first, determine its intended purpose, and use that analysis to guide the 
workflow.

Step 1: Examine the PDF File
When a PDF file is opened in Adobe Acrobat XI Pro, briefly analyze the document and note its 
characteristics. Does the document have:

•	 a small number of pages or many pages

•	 scanned pages

•	 text, links, graphics or a mixture of elements

•	 headings and/or lists

•	 data tables

•	 mathematical formulas, subscripts, superscripts, or other font attributes

•	 form fields

•	 annotations such as comments, revision marks, etc.

•	 multiple columns of information

•	 complex layouts and articles that span different pages

•	 multimedia

•	 multiple languages

The greater number of document features and complex layouts, the more time it may require to 
make the document accessible.

Step 2: Add Document Properties and Interactive Features
There are several document properties that must be set to ensure the document is accessible. In 
addition, interactive features such as links and bookmarks can be added at this step. Properties 
to set include

•	 document title

•	 document subject

•	 document author

•	 document keywords

•	 security settings that are compatible with assistive technology

Acrobat XI Pro PDF Accessibility Repair Workflow
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Document Title, Subject, Author, and Keywords

Specifying the document title ensures there is a programmatic method to identify the document 
and may help provide metadata to searches performed by users of assistive technology. 
A document subject and author provide additional description about the document. The 
document keywords field allows metadata to be provided about the document, which makes it 
easier to find.

To set the document properties:

•	 Open the Document Properties dialog: Choose File > Properties

•	 Activate the Make Accessible Wizard—the Add Document Description 
command is the first item to run

Set the following properties:

1.	 Enter a title in Document Title area of the Description tab. 

2.	 Enter a subject

3.	 Enter an author

4.	 Enter keywords that may be used to improve the document’s searchability

5.	 Select the OK button

Acrobat XI Pro PDF Accessibility Repair Workflow
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Figure 12.  The Description Dialog Generated by the Make Accessible Wizard

Set Security That Permits Accessibility

It is important to ensure the Acrobat XI security settings permit access to the document by 
assistive technology. Verify that the Acrobat XI or Adobe Reader XI security settings do not 
prohibit access by assistive technology by checking the Security tab of the Document Properties 
dialog.

1.	 Open the Document Properties dialog: Select File > Properties

2.	 Select the Security tab of the Document Properties dialog (See “Figure 13. 
Security Tab Location in Document Properties Dialog” on page 34)

Acrobat XI Pro PDF Accessibility Repair Workflow
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Figure 13.  Security Tab Location in Document Properties Dialog

3.	 Determine the security level needed. If security is not required, security 
need not be set—by default this will allow assistive technologies to access 
the document content.

4.	 Set security. When security is required, select “Password Security” as the 
security method from the drop-down list. In the Permissions section of 
the Password Security Settings dialog, verify that the box labeled “Enable 
text access for screen reader devices for the visually impaired” is checked. 
This is the default setting for Adobe Acrobat XI and Adobe Reader XI (See 
“Figure 14. Password Security Settings” on page 35).

Acrobat XI Pro PDF Accessibility Repair Workflow
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Figure 14.  Password Security Settings

Create Accessible Links

Links allow users to quickly move to another part of a document, to related information in a 
different document, or to a desired website.

For URLs to be accessible to users of screen readers, they must be converted to active links and 
be correctly tagged in the PDF file. 

Note: 	 If the document was tagged during conversion from an authoring application to 
Adobe PDF, the links and URLs in the document are most likely already active 
and included in the tag tree and thus accessible to users of assistive technology. 
The links should be verified and any additional links added to the document must 
follow this process to ensure access. 

Acrobat provides several ways to create active links for text, objects, and URLs in a PDF 
document: 

•	 Link tool

•	 Create from URLs in document

•	 Create Link Command

These methods differ in how they affect the tag tree. The best way to create accessible links 
is with the Create Link command. This command adds the proper tags, including a special 
LINK OBJR tag which can not directly be entered into the tag tree. Without this link object tag, 
keyboard-only users and users of screen readers will not have access to the link. Although it is 
necessary to create active links one by one, using the Create Link command provides the fastest 
results and the least amount of follow-up work to make the links accessible to screen readers 
and keyboard-only users. Intra-document links in Acrobat only move and scroll to a particular 
area of a page and thus cannot be used to move to a specific line, word, or paragraph on a page. 
Bookmarks, however, can set focus on a specific tag, allowing assistive technology to move to a 
particular word, line, or paragraph within a page. You may also edit the tag tree to add additional 
actual text to the new links to ensure they are unique and descriptive.

Acrobat XI Pro PDF Accessibility Repair Workflow
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Note: 	 Automatically detected URLs in PDF documents are not accessible. Avoid using 
the Create Links from URLs command (Tools> Document Processing > Create 
Links from URLs.

Note: 	 The General Preference option, “Basic tools: Create Links from URLs” also does 
not allow users of the keyboard-only or screen readers to access a link. This 
option must not be relied upon for ensuring access to links.

Note: 	 Creating links with Acrobat XI Standard does not generate any tags for the 
links.

Perform the following steps to make links active and add them to the tag tree:

1.	 Activate the Selection tool for text and images

2.	 Select the text or object you want to link. 

3.	 Right-click or press the applications key (Windows) on the selection, and 
choose Create Link from the context menu. 

4.	 In the Create Link dialog box, select the appropriate options, and then 
follow the on-screen instructions to specify a URL, page view, or file as the 
link target. 

By default, the selected text for each link becomes the link text. If the document is tagged, the 
proper link tags will be added in the appropriate place in the structure tree. If the document is 
not yet tagged, the appropriate link tags will be generated when the document is tagged.

After all the links are added, the tag tree can be edited (refer to step 6 on page 52) to add 
additional text descriptions to the links via the “actual text” property. Adding actual text can help 
clarify the link’s purpose and make the link text unique.

Add Bookmarks

A bookmark is a type of link with representative text in the Bookmarks panel in the navigation 
pane. Each bookmark goes to a different view, page, or structural element in the document. 
Bookmarks can be generated automatically during PDF creation from the table-of-contents 
entries of documents created by most desktop publishing programs. These bookmarks are often 
tagged and can be used to navigate within the PDF. Bookmarks can also provide a visual outline 
of the logical structure of the document.

Initially, a bookmark displays the page that was in view when the bookmark was created. 
In Acrobat, bookmark destinations can be set as each bookmark is created. However, it is 
sometimes easier to create a group of bookmarks, and then set the destinations later. 

In Acrobat, bookmarks can be used to mark your place in the PDF, or to jump to a destination or 
structural element in the PDF, another document, or a web page. Bookmarks can also perform 
actions, such as executing a menu item or submitting a form. For bookmarks to move focus 
by keyboard or assistive technology to a certain word, line, link, or paragraph, use the “create 
bookmark from structure” option in the Options menu of the Bookmarks panel. 
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Figure 15.  The New Bookmark from Structure option in the Bookmark options 
context menu

Note: 	 An Acrobat user can add bookmarks to a document only if the security settings 
allow it. If this security setting must be disabled, ensure bookmarks are added to 
the document before publishing.

Set Initial View/Open Options

There are several options that can be set to assist users with disabilities when the document 
loads. When the Make Accessible Wizard Set Open Option is run, the document metadata is set 
to the document title. In addition to the wizard, options can be set this way:

1.	 Open the Document Properties Dialog

2.	 Activate the Initial View page tab

3.	 Set Page Layout to “single” or “single page continuous”

4.	 Set Window Options: Show to “Window Title”

5.	 Set the Navigation Tab dropdown to “Bookmarks Panel and Page”

6.	 Activate the OK button

Step 3: Perform OCR on Scanned Document
A common method for making PDF documents is to place a paper copy of a document into a 
scanner and view the newly-scanned document as a PDF with Adobe Acrobat. Unfortunately, 
scanners only create an image of text, not the actual text itself. This means the content is not 
accessible to users who rely on assistive technology. Additional modifications must be made to 
make the document accessible.

Note: 	 If the PDF document is not a scanned document or it has previously undergone 
optical character recognition (OCR), skip this discussion and proceed to “Step 4: 
Add Form Fields and Set the Tab Order” on page 41.

How to Determine if a PDF File is a Scanned Document

There are many ways to determine if a PDF file originated from a scanned page:
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The Page Appears to be Skewed 

Sometimes sheets are not properly fed into the scanner. The result is the page appears to be 
crooked, or skewed on the screen . Lines of text will not be straight but will appear to slant up or 
down. 

Figure 16.  Skewed Text Indicates a Scanned PDF

Search for Characters that Appear on the Page

Use the find command in Acrobat to search for text that appears on the page. Select Edit > Find 
and type a term that appears on the page in the search field.

If the document was scanned, Acrobat will not find the search item but will display the message: 
“Acrobat has finished searching the document. No matches were found.”

Zoom in and Check for Jagged Edges on Smooth Characters

Scanned images are bitmaps (See “Figure 17. Bitmapped Text Appearance” on page 39). 
The edges of curves on bitmapped images will not appear to be smooth or rounded but will be 
jagged, as shown in the sample illustrating the word “Writing” in Figure 17 on page 39. Use 
the Marquee Zoom tool in Acrobat to define the area and magnify the edges of curved letters 
such as “c”, “s”, and “o”. Text that has undergone the OCR process using the ClearScan option will 
display edges that are smoother but still uneven or lumpy where there should be smooth curves, 
as shown in the illustration of the of the words “Quality” and “region” in Figure 18 on page 39. 
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Figure 17.  Bitmapped Text Appearance

Figure 18.  ClearScan Text Appearance

Use Assistive Technology or the Read Out Loud Feature

Acrobat XI Pro can detect the presence of assistive technology, and if it encounters a scanned 
document, Acrobat will announce an audible empty page warning and display the Scanned Page 
Alert dialog (See “Figure 19. Scanned Page Alert Dialog” on page 40). 
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Figure 19.  Scanned Page Alert Dialog

Perform OCR on a Scanned Document

Perform Optical Character Recognition (OCR) to convert the bitmap image of text to actual 
characters. In Acrobat XI Pro, this can be performed three ways:

•	 Make Accessible Wizard: Recognize Text� using OCR command

•	 With assistive technology running, open the document. When the 
Scanned Page Alert dialog appears, select “OK” from the Scanned Page 
Alert dialog (See “Figure 19. Scanned Page Alert Dialog” on page 40). 

•	 The Recognize Text pane can also be used in the Acrobat XI Pro Tools 
pane. 

•	 Activate View > Tools > Text Recognition > Choose In This File/In 
Multiple Files (See “Figure 20. Recognize Text Dialog and Recognize 
Text Settings” on page 41). 

The non-wizard methods will display the Recognize Text panel when activated. There is an 
option of recognizing the entire document, the current page, or a range of pages within the 
document. Use the Edit button in the scanned page dialog to set the desired characteristics for 
the resulting file. This “Recognize Text—General Settings” dialog appears also when the Make 
Accessible Wizard is run. The options to choose are:

•	 Primary OCR Language. Acrobat does not recognize a document’s 
language itself—a user must indicate which language is used.

•	 PDF Output Style. This option should be set to ClearScan. ClearScan will 
allow the resulting PDF to “reflow”. Reflow allows the text on the page 
to be enlarged without displaying horizontal scroll bars. As the text size 
increases, the text wraps so content is not lost in the margins. The other 
two options, “Searchable Image” and “Searchable Image Exact”, will also 
work with assistive technology but will result in a PDF file that does not 
reflow.

•	 Downsample to. Downsampling should be set to the highest resolution as 
measured in dots per inch (dpi). This should be 600 dpi.
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Figure 20.  Recognize Text Dialog and Recognize Text Settings

For additional information on performing optical character recognition using Adobe Acrobat, 
refer to the Acrobat XI Pro Help.

Step 4: Add Form Fields and Set the Tab Order
To determine if a PDF file is meant to be an interactive form, examine the file for the presence of 
form fields, or areas in the document that ask for information such as name, address, preference, 
etc. Boxes or fields drawn on the page can also indicate that the document is meant to function 
as a form. If the form is to be completed online, rather than on paper, then the form is meant 
to be an interactive form, and the form elements must be made accessible. Even when a form 
is meant to be filled out on paper, it can be very beneficial to users with disabilities to provide 
the form in electronic format with accessible forms. For example, this will allow users who are 
blind or visually impaired to fill out the form electronic privately, even if it is not submitted 
electronically.

The Make Accessible Wizard contains a command to Detect Form Fields and Set Tab Order to 
follow the document structure. The wizard will ask if the document is meant to be a fillable form, 
and then it will automatically detect form fields.

Please refer to the document Acrobat XI Accessible Forms for instructions on how to make 
electronic forms accessible to people with disabilities. This document provides instructions for 
creating form fields manually or making form fields accessible after automatic detection.

Step 5: Set the Document Language
Setting the document language in a PDF enables some screen readers to switch to the 
appropriate language. The document language can be set for an entire document with Acrobat 
Pro or Acrobat Standard. The document language for specific portions of a multi-language 
document can be set only with Acrobat Pro (See “Figure 21. Setting the document language” 
on page 42).

 Set the Language for an Entire Document

1.	 Open the Document Properties dialog: Choose File > Properties

2.	 Select a language from the Language menu in the Reading Options area of 
the Advanced tab. 

3.	 Activate the OK button.

Set the Language for an Entire Document to a Language not in the Language Menu

1.	 Open the Document Properties dialog: Choose File > Properties 
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2.	 Enter the ISO 639 code for the language in the Language field in the 
Reading Options area of the Advanced tab. For more information, refer to 
the ISO Language Codes on http://www.loc.gov/standards. 

3.	 Activate the OK button

Set the Language for Individual Sections or Words

Please refer to Section 6 on page 52 for information on setting the language of specific text 
using the Tags panels.

Figure 21.  Setting the document language

Step 6: Add Tags to the Document
Tagging is essential for PDF accessibility. Tags establish logical reading order and to provide 
a means for indicating structure and type, adding alternative text descriptions to non-text 
elements and substitute text (referred to as actual text) for elements in the PDF document.

If you’ve followed each step so far, your PDF document is searchable either from optical 
character recognition or through the native document conversion. Any desired interactivity has 
been added in the form of navigational controls or interactive form fields. The next step is to 
add tags to the document if it has not been tagged. This section addresses the addition of tags, 
while “Step 7: Examine and Repair the Tag Structure” on page 52 explains how to fix tags and 
properly tag complex layouts and elements.

Note: 	 If the PDF document has been tagged, skip this discussion and proceed to “Step 
7: Examine and Repair the Tag Structure” on page 52.

Determine if the Document has been Tagged

There are several ways to determine if a PDF file has been tagged:

Acrobat XI Pro PDF Accessibility Repair Workflow

42



Adobe® Acrobat® XI Pro Accessibility Guide: Best Practices for PDF Accessibility

View Document Properties 

1.	 Open the Document Properties dialog: File > Properties.

2.	 Look for the “Tagged PDF” label n the lower left hand corner of the 
Description tab.

Figure 22.  Tagged PDF File Property

Reveal the Tags Panel 

1.	 Open the Tags panel. 

Select View > Show/Hide > Navigation Panes >Tags.

2.	 Examine the Tags panel. 

A tagged document will show tags and a structure tree descending from 
the root node. To fully expand the entire tree, Control + click on the root 
node labelled “Tags”.

An untagged document will display the words “No Tags Available” as its 
root and no structure tree will appear.
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Figure 23.  No Tags Available in Structure Panel

Figure 24.  Structure Panel Showing Tags Tree

In some cases, a document may not be considered tagged by Acrobat even though a structure is 
visible in the Tags panel. To indicate the document is tagged:

1.	 Select the Options icon from the Tags panel.

2.	 Ensure the “Document is Tagged PDF” option is checked.
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Figure 25.  “Document is Tagged PDF” Indicator in a Structured Document

Run the Accessibility Checker

The Accessibility Checker can perform a thorough check for many common accessible issues 
found in PDF documents, including missing tags. For a complete guide on using the Accessibility 
Checker in Acrobat please refer to the document “Acrobat XI Access Checker”. The section below 
will only specifically address using the checker to determine if tags are missing.

To run the Accessibility Checker to determine if the document is tagged, perform the following: 

1.	 Display the Accessibility Pane

In Adobe Acrobat XI Pro, the Accessibility tool pane is not shown by 
default. Select View > Tools > Accessibility from the Adobe Acrobat XI Pro 
menu to show the pane.

2.	 Select the Full Check command from the Accessibility pane (See “Figure 
26.  Acrobat XI Pro Accessibility Pane with Full Check Command” on 
page 46).

Selecting the Full Check command opens the Accessibility Full Check 
dialog (See “Figure 27.  Acrobat XI Pro Accessibility Checker Dialog” on 
page 46). 

3.	 Choose how you would like the results displayed.

The results can be saved as an HTML file, or as comments placed where 
the accessibility problems are detected. 

4.	 Select a page range if a check is needed for individual sections of a 
document. 

5.	 Choose the items you want to test from the four categories in the drop-
down menu (Document; Page Content; Forms, Tables and Lists; and 
Alternate Text and Headings).

6.	 Select the Start Checking button. 
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Figure 26.   Acrobat XI Pro Accessibility Pane with Full Check Command

Figure 27.   Acrobat XI Pro Accessibility Checker Dialog

The results are displayed in the Accessibility Checker panel in a tree format, which allows the 
user to navigate through each error the Checker encountered. (See “Figure 28.  Acrobat XI Pro 
Accessibility Checker Panel” on page 47). Note the areas under Document, Page Content, 
and Forms, Tables and Lists that are related to tags. (See “Step 9: Use the Accessibility Checker to 
Evaluate the PDF File” on page 78).
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Figure 28.   Acrobat XI Pro Accessibility Checker Panel

Use the Touch Up Reading Order Tool (TURO)

Another way to check for the presence of tags is to display the Touch Up Reading Order tool or 
TURO. To display the Touch Up Reading Order tool, if the Accessibility panel is not already on 
display, select View > Tools > Accessibility from the Adobe Acrobat XI Pro menu. Then select the 
Touch Up Reading Order command under the Accessibility panel (See “Figure 29. Displaying 
the Touch Up Reading Order Tool” on page 48).

A tagged document will display shaded areas on the page that are numbered (See “Figure 30. 
Viewing a Tagged Document with the Touch Up Reading Order Tool” on page 48). An 
untagged document will not display these numbered rectangles (See “Figure 31. Viewing an 
Untagged Document with the Touch Up Reading Order Tool” on page 49).
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Figure 29.  Displaying the Touch Up Reading Order Tool

Figure 30.  Viewing a Tagged Document with the Touch Up Reading Order Tool
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Figure 31.  Viewing an Untagged Document with the Touch Up Reading Order Tool

Add Tags to an Untagged Document

Tags can be added to untagged documents using Adobe Acrobat XI Pro. There are several ways 
to do this:

•	 Add Tags from the Accessibility tool pane

•	 Add Tags from the Accessibility Check

•	 Add Tags from the Tags panel

Add Tags from the Make Accessible Actions Wizard

1.	 Open the Make Accessible Wizard

2.	 Activate the “Add Tags to Document” command to add tags to the document 
and generate a Recognition Results report for adding tags.

3.	 Verify the tags. Refer to the section “The Recognition Results Report for 
Adding Tags” on page 52
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Figure 32.  The Make Accessible Wizard with Add Tags to Document Command

Add Tags with the Accessibility Checker

When the document is not tagged at all, “Tagged PDF” will be listed as “failed” under the 
Document tree item. To add tags to the document: Refer to “Figure 28.  Acrobat XI Pro 
Accessibility Checker Panel” on page 47

1.	 Right click or press the applications key (Windows) on the “Tagged PDF—
Failed” tree item

2.	 Choose Fix

3.	 Verify tags have now been added to the document

A Recognition Report for adding tags has been generated. Refer to the section “The Recognition 
Results Report for Adding Tags” on page 52.

When the document was tagged but specific content is still missing tags:

1.	 Select the untagged content in the tree.

2.	 Select the Move or Make Changes to Object tool in the Quick Tools 
toolbar.
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3.	 Select the highlighted object in the document pane.

4.	 Activate the Tags panel.

5.	 Select the desired location to insert the tag in the tree structure.

6.	 If a new element is needed, select Options and choose New Element 
followed by the desired element (the new tag will appear below the 
selection).

7.	 Right-click the desired element.

8.	 Choose Create Tag from Selection

Figure 33.  Create Tag from Selection Context Menu Item

Note: 	 It is useful to check the “highlight content” context menu item shown in Figure 
17 Create Tag from Selection Context Menu Item above. This option will highlight 
the corresponding item from the tag tree in the document pane with a blue 
rectangle.

Add Tags Manually via the Tags Panel

With the Tags panel open, select “Add Tags to Document from the Options button, or with the 
Accessibility panel open in the Tools pane, select the “Add Tags to Document” command (See 
“Figure 34. Adding Tags to an Untagged PDF File” on page 52).

A Recognition Report for adding tags has been generated. Refer to the section “The Recognition 
Results Report for Adding Tags” on page 52 for more details.

Acrobat XI Pro PDF Accessibility Repair Workflow

51



Adobe® Acrobat® XI Pro Accessibility Guide: Best Practices for PDF Accessibility

Figure 34.  Adding Tags to an Untagged PDF File

The Recognition Results Report for Adding Tags

If Acrobat encounters potential problems while adding tags to the document, the Add Tags 
Report opens in the navigation pane. The report lists potential problems by page, provides a 
navigational link to each problem, and offers suggestions for fixing them. This is similar to the 
Accessibility Checker Report that is produced when an accessibility full check is run as described 
in “Step 9: Use the Accessibility Checker to Evaluate the PDF File” on page 78.

Remember that the automatically generated Recognition Results report requires human 
intervention to determine the best solution. For example, the report might state that an element 
has been tagged as a figure and requires alternate text to make it accessible. However, that figure 
may be a background design element that doesn’t convey any meaning to the user. 

Note: 	 The Add Tags Report highlights tagging-related problems only, and it is a 
temporary file that cannot be saved. Other accessibility issues, including reading 
order, can be assessed by using the Accessibility Checker.

Adding tags to a PDF may result in a tag structure that is overly complicated or problematic to fix 
manually. Specific tags can be removed directly via the Tags panel or via the Touch Up Reading 
Order tool. When a layout table is used, for example, the tagged table structure should be 
removed to create a cleaner, simpler tagging structure.

Step 7: Examine and Repair the Tag Structure
There are several tools available within Adobe Acrobat XI to repair and set the logical tag 
structure of the document. These include the Touch Up Reading Reader Order tool, the Order 
panel, the Tags panel, and the Content panel. The Touch Up Reading Order tool provides the 
easiest visual tool for tagging and setting order. However, it is limited in the types of structural 
elements that can be set. The Read Out Loud tool, which provides basic text-to-speech access 
for PDF files, uses the content order found in the Order panel. Assistive technologies such as 
screen readers, on the other hand, follow the order found in the Tags panel.

When order changes are made in the Touch Up Reading Order tool or the Order panel, 
order changes are made in both the Tags panel and the Contents panel automatically. Thus 
the Tags panel and Order panel generally should be synchronized—although they can get 
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unsynchronized. The Touch Up Reading Order tool (See “Figure 36. Touch Up Reading Order 
Tool” on page 54) can be used to quickly determine whether basic structural tags and reading 
order have been applied to a document. 

The Touch Up Reading Order tool displays tagged page content in shaded rectangles. Each 
rectangle is numbered and indicates the reading order or tag type of the item on the page. The 
reading order of items can also be verified by displaying the Order navigation panel.

Figure 35.  The Order Navigation Panel

Note: 	 When the PDF document is properly tagged, proceed to “Step 9: Use the 
Accessibility Checker to Evaluate the PDF File” on page 78.

The Tags panel is the most advanced panel for tagging PDF files and provides the most 
flexibility. Advanced users may primarily use the Tags panel for tagging documents in 
combination with several toolbar items such as the Move or Make Changes to Object tool and 
the Selection tool for text and images. Advanced users will find the Touch Up Reading Order 
tool useful for working with complex data tables and for selecting and tagging text that spans 
multiple objects.

Touch Up Reading Order Tool (TURO)

The Touch Up Reading Order tool provides the easiest way to fix basic reading order and tagging 
issues. When the Touch Up Reading Order tool is activated, a dialog displays an overlay of 
highlighted rectangles showing the reading order and tag type of page content. Each tagged 
region is numbered and highlighted with gray or colored blocks (the color is adjustable from the 
TURO dialog); the lower the number, the higher the content appears in the page’s reading order. 
The reading order of page content should be addressed first, followed by other semantic tasks.

Use the Touch Up Reading Order tool to perform the following accessibility tasks:

•	 Visually check, and then repair, the reading order of page content

•	 Display the tag type of page content

•	 Tag fillable form fields and their labels

•	 Assign accessible labels for form fields and alternative text for images
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•	 Specify heading structure

•	 Create formula, figure and caption tags 

•	 View table structure including table headers and data cells

•	 Fix the tagging of simple tables, and prepare complex tables for more 
advanced manipulation in the logical structure tree

•	 Remove decorative content, such as ornamental page borders, from the 
logical structure tree

Figure 36.  Touch Up Reading Order Tool

Selecting the Touch Up Reading Order Tool

To display the Touch Up Reading Order tool, if the Accessibility panel is not already displayed, 
select View > Tools > Accessibility from the Adobe Acrobat XI Pro menu. Then select the Touch 
Up Reading Order command under the Accessibility pane (See “Figure 29. Displaying the Touch 
Up Reading Order Tool” on page 48).

When the Touch Up Reading Order command is selected, a dialog box opens that displays 
the overlay highlighted rectangles that show the order of page content (See “Figure 37. Page 
Content Display with the Touch Up Reading Order Tool” on page 55).
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Figure 37.  Page Content Display with the Touch Up Reading Order Tool

Each highlighted region is numbered and highlighted with gray or colored blocks (colors can be 
customized from the dialog); the numbers indicate each region’s position in the page’s reading 
order. To display the contents corresponding tag type rather than reading order, check the 
“Structure Types” radio button.

Touch Up Reading Order Tool Options

Select Touch Up Reading Order options from the dialog box, from the pop-up menu that appears 
when the right mouse button is pressed in a highlighted region, or from the Options menu in the 
Order tab. The Touch Up Reading Order tool includes the following options:

•	 Text . Tags the selection as text.

•	 Background. Tags the selection as a background element, or artifact, 
removing the item from the tag tree so that it doesn’t appear in the reflowed 
document and isn’t read by screen readers.

•	 Figure. Tags the selection as a figure. Text contained within a figure tag is 
defined as part of the image and is not read by screen readers. 

•	 Figure/Caption. Tags a selected figure and caption as a single tag. Any 
text contained in the tag is defined as a caption. Useful for tagging photos 
and captions and preventing caption text from being incorrectly added to 
adjacent text blocks. Figures may require alternate text. 

•	 Table. Tags the selection as a table after the selection is analyzed to 
determine the location of headings, columns, and rows. 

•	 Cell. Tags the selection as a table or header cell. Use this option to merge 
cells that are incorrectly split.

•	 Form Field. Tags the selection as a form field.

•	 Formula. Tags the selection as a formula. Because speech software may 
handle formula tags differently from normal text, it may be necessary to add 
a description using alternate text. 

•	 Heading 1, Heading 2, Heading 3, Heading 4, Heading 5, Heading 6. Tags 
the selection as a first, second, third, fourth, fifth or sixth level heading tag. 
Heading elements can be converted to bookmarks to help users navigate 
the document. 
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•	 Show Page Content Groups. Outlines each content group, and allows the 
user to select between Page content order, which displays content based 
on it’s numerical order value, and Structure types, which displays content 
type, for example Paragraph or Figure, in place of numerical values.

•	 Show Page Content Order. Shows content elements as highlighted areas 
that contain numbers to indicate the reading order. The rectangle next to 
this entry is a color swatch. Specify the desired highlight color for page 
content order by clicking the color swatch. 

•	 Show Table Cells. Highlights the content of individual table cells. The 
rectangle next to this entry is a color swatch. Specify the highlight color for 
Table Cells by clicking the color swatch. 

•	 Show Tables And Figures. Outlines each table and figure with a crossed-out 
box. The box also indicates whether the element includes alternate text. The 
rectangle next to this entry is a color swatch. Specify the highlight color for 
Tables and Figures by clicking the color swatch. 

•	 Delete Selected Item Structure. Removes the structure from the selected 
item.

•	 Clear Page Structure. Removes the tagging structure from the page. Use 
this option to start over and create a new structure if the existing structure 
contains too many problems. 

•	 Show Reading Order Panel. Opens the Order tab to allow reordering of the 
highlighted content. 

The following items are only displayed when right-clicking a corresponding item in the 
document pane while the Touch Up Reading Order tool is activated:

•	 Table Editor. Automatically analyzes the selected table into cells and 
applies the appropriate tags. Table Editor is only available for content that is 
tagged as a table. 

•	 Edit Table Summary. Available via context menu on a highlighted table. 
Allows the user to add or edit a text description of the table that is read by a 
screen reader or other assistive technology.

•	 Edit Alternate Text. Available via context menu on a highlighted figure. 
Allows the user to add or edit a text description about the figure properties 
that is read by a screen reader or other assistive technology. 

•	 Edit Form Field Text. Available via context menu a form field. Allows the 
user to add or edit a form field text description that is read by a screen 
reader or other assistive technology. 

Tips for using the Touch Up Reading Order Tool

When using the Touch Up Reading Order tool, consider the following:

•	 Save the document (or a copy of it) before using the Touch Up Reading 
Order tool. Undo can not be used to reverse changes made with this tool 
or the Tags panel. Reverting to a saved document is the only way to undo 
such a change. 

•	 Choose View > Page Display > Single Page, when using the Touch Up 
Reading Order tool. When the Clear Structure button is activated, Acrobat 
clears tags from all visible pages—even pages that are only partially visible. 
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Checking Read Order with the Touch Up Read Order Tool

The reading order can quickly be checked by using the Touch Up Reading Order tool. It is 
possible to use this tool to add alternate text to images and correct many types of tagging 
problems that are outlined in the report that Acrobat generates when adding tags to a PDF. 

Reading order issues are readily apparent when using the Touch Up Reading Order tool. Each 
section of contiguous page content appears as a separate highlighted region and is numbered 
according to its placement in the reading order. It may be helpful to turn off the option “Display 
Like Elements in a Single Box” to change the order of similar elements that appear to be grouped 
with one number in the Order. This option can be set using the “Options” menu in the Order 
panel.

Within each region, text is ordered left to right and top to bottom. (This order can be changed 
in the Touch Up preferences.) If a single highlighted region contains two columns of text or 
text that will not flow normally, divide the region into parts that can be reordered. Because 
highlighted regions are rectangular, they may overlap somewhat, especially if their page content 
is irregularly shaped. Unless page content overlaps or is contained within two highlighted 
regions, no reading order problem is indicated. Page content should belong to no more than one 
highlighted region. 

The reading order of the highlighted regions can be changed by moving an item in the Order 
panel or by dragging the numbers on the page in the document pane. By reordering highlighted 
regions on the page, it is possible to make a figure and caption appear in the reading order at the 
specific point that they are referenced in the text. By changing the order of a highlighted region, 
the reading order can effectively be changed for an item without changing the actual appearance 
of the PDF.

To check the reading order with the Touch Up Reading Order tool:

•	 Select the Touch Up Reading Order tool.

•	 In the Touch Up Reading Order dialog box, select Show Page Content Order.

Note: 	 If highlighted regions do not appear in the document pane, the document does 
not contain tags. Tags will need to be added to the document (See “Step 6: Add 
Tags to the Document” on page 42).

The page view may be modified by doing any of the following: 

•	 To specify a highlight color, click on one of the color swatches, the small 
squares to the right of the check boxes for “Show page content groups”, 
“Show table cells” and “Show tables and figures.” Select the desired color 
from the swatch that pops up in the Touch Up Reading Order dialog.

•	 To highlight tables and figures, and to view alternate text for figures, select 
Show Tables And Figures checkbox.

•	 Check the reading order of text within each highlighted region. Zooming in 
can make this step easier. 

•	 It may be necessary to uncheck the display like elements in a single 
block checkbox to verify that elements within a single block are 
ordered correctly.

•	 Check the numbered order of all highlighted regions. If consecutive, 
numbered regions don’t follow one another, reorder them in the Order 
panel. 
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•	 Click Show Order Panel, and then select each content entry (in square 
brackets [ ]) in the Order panel to highlight that content region in the 
document pane. Use this method to find numbered regions that cannot be 
seen or located on the page.

Change the Reading Order by Dragging on the Page

•	 Select the Touch Up Reading Order tool.

•	 In the Touch Up Reading Order dialog box, select Show Page Content 
Groups: Page Content Order. 

•	 In the document pane, place the pointer over the number for the highlighted 
region to move, and drag it to where it to be read. The text-insertion pointer 
shows target locations within the text. 

Change the Reading Order using the Order Panel

In the Order panel, highlight an item in the list that corresponds to a numbered item in the 
document view. Push the item up or pull it down until it falls into the proper sequence.

•	 Select the Touch Up Reading Order tool. 

•	 In the Touch Up Reading Order dialog box, click Show Order Panel. 

•	 The Order panel shows a list of highlighted regions that appear in the 
document pane. 

•	 Push items up or drag them down to rearrange their order. (Note copy and 
paste keyboard commands can also be used).

Note: 	 Another way to display the Order panel is from the Acrobat X Pro menu. Select View > 
Show/Hide > Navigation Panes > Order.
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Figure 38.  Acrobat XI Pro Order Panel

Edit Tags with the Touch Up Reading Order Tool

Use the Touch Up Reading Order tool to create tags in untagged PDFs, or to add new tags 
to an existing structure. This manual tagging does not provide the same level of detail to the 
tagging structure as the Add Tags To Document command. For example, tags such as individual 
paragraphs, bulleted and numbered lists, line breaks, and hyphens. Sometimes it may be 
necessary to activate the “clear page structure” feature of the Touch Up Reading Order tool. 
Make sure that manual tagging is the only option before clearing the structure.

Tag a Region

With the Touch Up Reading Order tool active:

1.	 Drag within the document pane to select a region of the page that contains 
one type of content (for example, a text block).

•	 To add more page content to the current selection, Shift-drag.

•	 To remove page content from the current selection, Control-drag/
Command-drag.

2.	 Activate the appropriate button in the Touch Up Reading Order dialog box 
to specify the tag type.

Change the Tag for a Region

If a page element is not tagged incorrectly, change the tag type for the highlighted region.

1.	 Select the Touch Up Reading Order tool.

2.	 To select a highlighted region, click the number of a highlighted region.

3.	 Click the button for the tag type the highlighted region should be.

Add or Remove Content from a Tagged Region

The Touch Up Reading Order tool always displays as few highlighted regions as possible. If 
content within a highlighted region does not flow properly, it may be necessary to split a region 
to reorder it. Highlighted regions may also contain adjacent page content that is unrelated 
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or requires a different tag type. Page content may become orphaned from related elements, 
particularly if the content doesn’t fit within a rectangular shape. Use the Touch Up Reading Order 
tool to add or remove content from a region, or to split a region to reorder the content.

•	 Select the Touch Up Reading Order tool. 

•	 In the Touch Up Reading Order dialog box, unselect “Display like elements 
in a single box”

•	 In the document pane, select a highlighted region. 

Do one of the following: 

•	 To add content to the current selection, Shift-click the content to add. The 
pointer changes to include a plus sign (+).

•	 To remove content from the current selection, Control-click/Command-click 
the content to be removed. The pointer changes to include a minus sign (-).

•	 Click the button for the tag type to be highlighted.

Split a Region into two Regions

1.	 Select the Touch Up Reading Order tool. 

2.	 In the Touch Up Reading Order dialog box, unselect Display like elements in 
a single box. 

3.	 In the document pane, drag to select the content to create as the new 
region. 

4.	 Activate the desired tag button (such as text) in the dialog box. The 
highlighted region splits into two regions, numbered from left to right. 

5.	 To correct the reading order, click Show Order Panel, and drag the split 
region to the correct location in the Order panel. 

Note: 	 Regions can be combined by selecting each item in the Order panel (Shift+click) and 
then choosing the desired tag button in the Touch Up Reading Order dialog box or by 
choosing the tag type from the context menu.

Apply a Heading Tag

To help readers navigate a document and understand the logical structure of document content, 
tag content that represents a heading with the appropriate heading level to indicate its position 
in the document hierarchy. 

•	 Select the Touch Up Reading Order tool, and then select the heading text 
in the PDF. 

•	 In the Touch Up Reading Order dialog box, activate the button 
corresponding to the appropriate heading tag (for example, Heading 1, 
Heading 2). 

Remove Page Elements from the Tag Structure

Automatic tagging cannot always distinguish between instructive figures and decorative 
page elements. Items that visually enhance page layout, such as decorative borders, lines, or 
background elements, can add clutter to the structure layout and should be removed. Decorative 
elements may be tagged as figure tags instead of artifact elements that are not presented to 
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users of assistive technology. You can remove decorative and irrelevant page elements from the 
tag structure by redefining them with the Background (artifact) tag. Simply deleting these tags 
from the structure will prevent them be being seen by assistive technology but these untagged 
elements will then be flagged by the Accessibility Checker. Therefore it is best to tag these 
elements as artifacts by choosing the Background button of the Touch Up Reading Order tool..

1.	 Select the Touch Up Reading Order tool. 

2.	 In the Touch Up Reading Order dialog box, select Show Page Content Order 
and Show Tables And Figures. 

3.	 In the document pane, select the page element, and then click 
Background in the dialog box.

Apply a Figure Tag

Non-decorative figures must provide alternative text to users who cannot see them. Select an 
element and define it as a figure by using the Touch Up Reading Order tool. Once it is defined as 
a figure, add alternate text to describe it.

1.	 Activate the Touch Up Reading Order tool.

2.	 Select the figure by drawing a rectangle around it.

3.	 In the Touch Up Reading Order dialog box, activate the Figure button. 

4.	 In the document pane, right-click the region and choose Edit Alternate Text 
(See “Figure 39. Add / Edit Alternate Text with Touch Up Reading Order” 
on page 62). 

5.	 Enter the desired alternate text in the Alternate Text dialog (See “Figure 40. 
Touch Up Reading Order Alternate Text Dialog” on page 62), 

6.	 Select the OK button. 

Use the Touch Up Reading Order to tag figures with captions

Use the Touch Up Reading Order tool to correct tag figures with on-screen captions. Determine 
whether figures include caption. Typically this occurs when an image such as a graph or 
illustrative photograph is provided with text below or above it that describes or labels the figure. 
Background elements that should not be announced should be tagged as background elements.

Select the Touch Up Reading Order tool, and activate Show Tables And Figures in the dialog box. 

It may be necessary to do the following:

•	 If a figure with caption is not tagged as a figure/caption, select the desired 
image and text caption content, and then activate the Figure/Caption 
button in the dialog box.

•	 To remove text that was incorrectly combined with a figure, drag to select 
the text, and click the Text button in the dialog box.

•	 To include a caption that is visually grouped with the figure, select the figure 
and caption, and click the Figure/Caption button in the dialog box.

Add Alternate Text with the Touch Up Reading Order Tool

Screen reading software used by people who are blind or visually impaired cannot describe 
graphical elements that illustrate important concepts in a document. Thus, the document author 
must provide the description using alternate text. Figures are not recognized or announced by a 
screen reader unless alternate text is added to the tag properties. Alternate text that is applied to 
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text elements is not generally announced by screen readers. The actual text property must be set 
to change what is announced by screen readers for non-figure elements. To set alternative text 
for a figure:

1.	 Select the Touch Up Reading Order tool. 

2.	 Select Show Tables And Figures in the dialog box. Figures that are missing 
Alternate Text will have a flag indicating “Figure—No alternate text exists” 
(See “Figure 39. Add / Edit Alternate Text with Touch Up Reading Order” 
on page 62).

3.	 Right-click the figure, and choose Edit Alternate Text from the pop-up 
menu. (See “Figure 39. Add / Edit Alternate Text with Touch Up Reading 
Order” on page 62).

4.	 In the Edit Alternate Text dialog box, type a new (or edit an existing) 
description for the figure. (See “Figure 40. Touch Up Reading Order 
Alternate Text Dialog” on page 62).

5.	 Select the OK button.

Figure 39.  Add / Edit Alternate Text with Touch Up Reading Order

Figure 40.  Touch Up Reading Order Alternate Text Dialog

Using the Touch Up Reading Order Tool Table Editor

Tables pose a special challenge for screen readers because they present textual or numerical 
data to be easily referenced visually. Content within table cells can be complex and might 
contain lists, paragraphs, form fields, or another table.
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The Touch Up Reading Order Table Editor displays the selected table into cells and allows the 
user to apply additional table markup. The table must be tagged as a table before using TURO’s 
Table Editor command.

For best results when tagging tables, use the application that created the document to add tags 
when the PDF is created. If a PDF is not tagged and the source document is not available, add 
tags by using the Add Tags To Document command in the Accessibility pane. Most tables are 
properly recognized using this command; however, the command may not recognize a table 
that lacks clear borders, headings, columns, and rows. Use the Touch Up Reading Order tool to 
determine if the table has been properly recognized and to correct recognition problems such as 
missing cells. The Tags panel can also be used to manually tag data table elements.

Use the Table Editor to check and correct table tags. By viewing table tags, determine whether 
columns, rows, and cells have been correctly identified. Tables that lack well-defined borders 
and rules are often tagged incorrectly or contain adjacent page elements. It is possible to correct 
poorly tagged tables by selecting and redefining them; it is possible to split combined cells by 
creating a tag for each cell. 

1.	 Select the Touch Up Reading Order tool. 

2.	 Select the Show Tables And Figures button. 

3.	 If the table is not clearly labeled in the document pane, drag to select the 
entire table, and then click Table in the dialog box. 

4.	 Click Show Table Cells to make sure that all cells in the table are defined as 
individual elements.

If cells do not appear as separate elements: 

1.	 Use the Touch Up Reading Order tool to select a single cell from within a 
merged cell.

2.	 Select the Cell button in the dialog box. Repeat for each split merged cell.

Note: 	 If cells are not highlighted, the table might not use standard table formatting. Re-
create the table in the authoring application.

Add a Table Summary

With the cursor over the table, right click to add a Table Summary. The Edit Table Summary 
option is available in the menu that appears when a right-click is performed on a highlighted 
table. This allows the user to add or edit a text description about the table properties that may be 
read by a screen reader or other assistive technology.

Editng Table Tags

Place the Table in Editing Mode

There are two ways to place Tables in Table Editing Mode with the Touch Up Reading Order tool:

•	 With the cursor over the table, right click to select Table Editor from the 
context menu to place the table in Table Editing mode.

•	 Use the Order panel.

1.	 Activate the Show Order Panel button in the Touch Up Reading Order 
dialog. 
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2.	 Highlight a cell from the table in the Order panel. 

3.	 The Table Editor button in the Touch Up Reading Order tool becomes 
active. 

4.	 Select the Table Editor button on the Touch Up Reading Order dialog 
to place the table in Table Editing Mode (See “Figure 41. Using the 
Order Panel to Activate the Table Editor” on page 64).

Figure 41.  Using the Order Panel to Activate the Table Editor

Table Editor Options

In Table Editing mode, the borders of the table cells are highlighted. It is possible to change the 
color of the border (See “Figure 42. Table Editing Mode” on page 64). 

Figure 42.  Table Editing Mode

Right click on the table and choose “Table Editor Options” to display the options dialog. The 
Table Editor Options dialog allows users to control how table cells and table headers are 
displayed by Acrobat when using the Touch Up Reading Order Table Editor (See “Figure 43. 
Table Editor Options” on page 65).
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Figure 43.  Table Editor Options

Selecting Table Cells

Select individual cells by clicking within the borders with the mouse. Select multiple table cells 
by holding down Shift and clicking. (This is an efficient method for selecting the first row of data 
cells in a table which need to be changed to header cells.) Some properties for multiple cells can 
be set at once thus saving time tagging large and complex tables.

Edit Cell Properties

Once in Table Editing mode, right click to display the Table Cell Properties dialog. 

The Table Cell Properties dialog (See “Figure 44. Table Cell Properties” on page 66) can be 
used to: 

•	 Specify the type of a table cell (Header cell or Data cell)

•	 Set cell attributes that span more than one row or column

•	 Assign a scope of row, column, both, or none to header cells

•	 Assign a unique header ID for Table Headers

•	 Associate Data cells with Header IDs that have been created for the table
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Figure 44.  Table Cell Properties

To correct complex tagging issues in data tables, it may be necessary to use the Tags panel and 
the Table Editor in combination. For simple tables with only one row or column of header cells, 
the easiest approach is to set each cell in the header row or column to type “header cell”. Then 
set the scope on each cell to the appropriate item “row” for row headers on the left side of the 
table or “column” for column headers that appear across the top of a table. Data tables should 
always have headers tagged this way, or with IDs and headers.

For complex tables, those with more than one row or column of header cells IDs and headers 
must be used. IDs and headers refers to the method to associate data and header cells in data 
tables. This process is very similar to that of HTML data tables. When IDs and headers are used, 
the type of cells (header or data) should still be set but the scope option should not. Assign an 
ID property to each header cell. Then add mappings to the ID or IDs that label the cell in the 
Headers list. Headers are announced by screen readers in reverse order in the headers list.

Remove or Replace Document Structure Tags using the Touch Up Reading 
Order Tool

If the tags in a PDF file in Acrobat appear to be overly complicated and cannot be managed, it 
is possible to re-tag an already tagged document. To do this, first remove all existing tags from 
the tree. Use the Touch Up Reading Order tool to remove or replace the current structure. If 
the document contains mostly text, select a page and then remove headings, tables, and other 
elements to create a cleaner, simpler tagging structure. 

Remove All Tags from a PDF Document

The Touch Up Reading Order tool is very useful to create tags in untagged PDFs or to add new 
tags to an existing tagged structure, but the Add Tags to Document command provides more 
detail. For example, tags such as paragraphs, bulleted and numbered lists, line breaks, and 
hyphens are available from Add Tags to Document. Before clearing the existing structure, make 
sure that manual tagging is the only recourse.

To remove the tags from the entire PDF document, do the following:
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•	 Open the Tags tab (View > Navigation Panels > Tags) and select the root 
(topmost) tag, Tags. 

•	 In the Tags tab, choose Options > Delete Tag. 

Note: 	 The Clear Page Structure command in the Touch Up Reading Order dialog box 
removes all tags from the currently visible pages and not from any pages that are 
not visible.

Replace the Existing Tag Structure on a Page

This process works best in pages that contain a single column of text. If the page contains 
multiple columns, each column must be selected and tagged individually.

1.	 Select the Touch Up Reading Order tool. 

2.	 In the document pane, drag to select the entire page. The selection includes 
both text and non-text elements. 

3.	 Control-drag/Command-drag around non-text page elements—such as 
figures and captions—to deselect them, until only text is selected on the 
page. Click Text in the Touch Up Reading Order dialog box. 

4.	 In the document pane, select a non-text page element, such as a figure and 
caption, and click the appropriate button in the dialog box to tag it. Repeat 
until all page content is tagged. 

Complex Structures

To perform more advanced reading order and tagging tasks—such as tags table of contents, 
adding replacement (actual) text for blocks of text, removing obsolete tags, and adding 
replacement (actual) text to links—it may be necessary to use the Content panel and the Tags 
panel, which provide an advanced set of tools and features for manipulating PDF tags. The Touch 
Up Reading Order tool generally changes and synchronizes both of these panels, but the two 
can become out of sync. 

Content Panel

Use the Content panel to correct reflow problems in a PDF that cannot be corrected by using 
the Touch Up Reading Order tool. Take note that it is easy to damage a PDF by editing content 
objects as removing a content object will remove the object from the visual page. Be familiar 
with the PDF structure before changing anything. For comprehensive information about PDF 
structure, refer to the PDF Reference First Edition: Adobe Portable Document Format Version 
1.7, on the PDF reference page (English only) of the Adobe website.

The Content panel provides a hierarchical view of the objects that make up a PDF, including 
the PDF object itself. Each document includes one or more pages, a set of annotations (such as 
comments and links), and the content objects for the page, consisting of containers, text, paths, 
and images. Objects are listed in the order in which they appear on the page, similar to tags in 
the logical structure tree. However, objects in the Content panel do not require tags to view or 
change the object structure. 

To display the Content panel, choose View > Show/Hide > Navigation Panes > Content from the 
Acrobat XI menu.
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Click the plus sign (+) (Windows) or the triangle (Mac OS) next to the document name to view 
each page content entry. Control + click expands the entire content tree. The Content panel 
provides an option to show the corresponding tag in the Tags panel by activating the context 
menu and choosing “Show in Tags Panel”.

Note: 	 It is helpful to have Acrobat highlight items in the document view when the 
associated item in the Content panel is selected. By default, Acrobat will 
highlight content in the tag and content panel trees. To toggle the highlight 
feature on and off, from the Options Menu, select “Highlight Content” 
(See “Figure 45. Set Highlighting On for the Content Panel” on page 
68). 

Containers or objects can be moved by selecting them and doing one of the following: 

•	 Drag it to the desired location. 

•	 Choose Cut from the Options menu, select the tag above the location, 
and choose Paste from the Options menu (Standard Windows and Mac 
keystrokes also work).

Figure 45.  Set Highlighting On for the Content Panel

Note: 	 Container elements can’t be pasted directly to page elements. To move a 
container to another page, cut the container to move, select a container on 
the page to move the container to, and choose Paste from the Options menu. 
Then, drag the container out one level to the desired location.

Content Panel Options

In the Content panel, use the Options menu or right-click an object to choose from the 
following options:

•	 New Container. Adds a new container object at the end of the selected 
page or container. 
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•	 Edit Container Dictionary . Specifies the dictionary for the container. Errors 
in this dialog box may damage the PDF. This option is only available only for 
containers that include dictionaries. 

•	 Cut. Cuts and copies the selected object (not the related page content).

•	 Paste. Pastes content directly below the selected object at the same 
hierarchical level.

•	 Paste Child. Pastes content into the selected object as a child content item.

•	 Delete. Removes the object (not the related page content) from the 
document.

•	 Find Content From Selection. Searches for the object in the Content tab 
that contains the object selected in the document pane.

•	 Find. Searches for unmarked (untagged) artifacts, content, comments, and 
links. Options allow page search or document, and to add tags to found 
items.

•	 Create Artifact. Defines selected objects as artifacts. Artifacts are not read 
by a screen reader or by the Read Out Loud feature. Page numbers, headers, 
and footers are often best tagged as artifacts.

•	 Remove Artifact. Removes the artifact definition from the selected object.

•	 Highlight Content. When selected, highlights appear in the document pane 
around content that relates to a selected object in the Content tab.

•	 Show Metadata . Allows viewing and editing of image or object metadata.

•	 Properties. Opens the Object Up Properties dialog box.

Tags Panel

The Tags panel allows the viewing and editing of tags in the logical structure tree, or tags tree, of 
a PDF file. Tags in panel appear in a hierarchical tree order that indicates the reading sequence 
of the document by assistive technologies such as screen readers. The first item in this structure 
is the Tags root. All other items are tags representing standard PDF structure elements and are 
children of the Tags root. Tags use coded element types that appear in angle brackets (< >). 
Each element, including structural elements such as sections and articles, appear in the logical 
structure order by type, followed by a title and the element’s content or a description of the 
content. Structural elements are typically listed as container—or parent—tags and include 
several smaller elements—or child tags—within them. The tag description is not seen by users 
of assistive technology and can be used by the author to provide comments during the tagging 
process. 

Note: 	 It is possible to directly change tag types by pressing F2 or double clicking the tag 
name in the tree. Tag names are case-sensitive, and care must be taken to properly 
enter the angle bracket if this method is used to change the type of a tag.

Many tagging issues can be corrected by using the Touch Up Reading Order tool, but it is 
necessary to use the Tags panel to address detailed tagging of tables and substructure items—
such as paragraphs, lists, and sections that require multiple languages. First consider using the 
Add Tags To Document feature and the Touch Up Reading Order tool and then use the Tags 
panel to modify the tags.
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Note: 	 Important! Operations performed in the Tags panel cannot be undone with the 
Undo command. Save a backup copy of each document before beginning work 
on it in the Tags panel.

•	 To display the Tags Panel Choose View > Show/Hide > Navigation Panes > 
Tags.

•	 Expand or collapse the tag for an individual element or section by clicking 
on it.

•	 Expand or collapse the entire tree or a node on the tree that has children 
with Control-click the plus sign (Windows) or Option-click the triangle (Mac 
OS) next to the Tags root to show all tags in the logical structure tree or 
press Shift+8 to expand all tags.

Note: 	 You may find it helpful to toggle whether Acrobat highlights items in the 
document view when the associated item in the Tags panel is selected. From the 
Tags panel options menu, “Highlight Content” can be turned on or off—it is on 
by default in Acrobat XI. (See “Figure 45. Set Highlighting On for the Content 
Panel” on page 68). It is also possible to show the corresponding content tag 
in the Content panel from the Tags panel by activating the context menu and 
choosing “Show in Content Panel”.

Figure 46.  Toggle Content Highlighting On/Off for the Tags Panel

Edit tags in the Tags Panel

There are many actions that can be taken on a tag within the Tags panel. These include but are 
not limited to:

•	 Adding a tag

•	 Creating a tag from the document selection

•	 Editing a tag title

•	 Changing a tag location

•	 Changing the tag type for an element
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•	 Deleting a tag

To reveal the Object Properties (See “Figure 47. The Object Properties Dialog: Tag Tab” 
on page 71) for any tag, select the desired tag in the Tags panel and perform one of the 
following:

•	 Right click (or activate the context menu) and select Properties from the 
context menu.

•	 Select Properties from the Tags Panel Option Menu.

Figure 47.  The Object Properties Dialog: Tag Tab 

Edit a Tag Title

From the Tags panel:

1.	 Expand the section of the desired logical structure to edit.

2.	 Select the desired tag to edit.

3.	 Choose Properties from the Options menu.

4.	 Enter text in the Title box.

5.	 Select the Close button.

Note: 	 The F2 command can also be used within the tags tree to edit the tag type and title. 
Make sure that the tag type does not get overridden.

Move a Tag

From the Tags panel:
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1.	 Expand the Tags root to view all tags.

2.	 Select the Tag icon of the element to move.

3.	 Then do one of the following:

•	 Drag the tag to the desired location. When dragging, a line appears at 
available locations to place the tag.

•	 Choose Cut from the Options menu, and select the tag that appears 
above the desired location to paste the cut tag. From the Options menu, 
choose Paste to move the tag to the same level as the selected tag, or 
choose Paste Child to move the tag within the selected tag.

Change the Element Type

From the Tags panel:

1.	 Expand the section of the logical structure that to change.

2.	 Select an element.

3.	 Choose Properties from the Options menu or from the context menu.

4.	 Choose a new element type from the Type menu.

5.	 Select the Close button.

Tags Panel Options

In the Tags panel, use the Options menu or right-click a tag in the logical structure tree to choose 
from the following options:

•	 New Tag. Creates a new tag in the logical structure tree after the currently 
selected item. Specify type and title of the new tag. 

•	 Cut . Removes the selected tag from its current location and puts it on the 
clipboard. 

•	 Paste. Places the tag on the clipboard into the location specified, replacing 
the selected tag.

•	 Paste Child. Places the tag on the clipboard into the location specified, as a 
child of the selected tag. 

•	 Delete Tag. Removes the selected tag. 

•	 Find Tag From Selection. Searches for the tag in the Tags tab that contains 
the text or object selected in the document pane. 

•	 Create Tag From Selection. Creates a new tag in the logical structure tree 
after the item selected in the document pane. Specify the type and title of 
the new tag. 

•	 Find. Searches for artifacts, OCR suspects, and unmarked (untagged) 
content, comments, links, and annotations. Options allow searching the 
page or document and adding tags to found items. 

•	 Change Tag To Artifact. Changes selected tags to artifacts and removes the 
tagged content from the structure tree. 

•	 Copy Contents To Clipboard. Copies all content contained within the 
selected tags. 
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•	 Edit Class Map. Allows the addition, modification, and deletion of the class 
map, or style dictionary, for the document. Class maps store attributes that 
are associated with each element.

•	 Edit Role Map. Allows the addition, changing, and deletion role maps 
for the document. Role maps allow each document to contain a uniquely 
defined tag set. By mapping these custom tags to predefined tags in 
Acrobat, custom tags are easier to identify and edit.

•	 Tag Annotations. When selected, all new comments and form fields are 
added to the tag tree; existing comments and form fields aren’t added 
to the tag tree. Highlight and Underline comments are automatically 
associated and tagged with the text that they annotate and don’t require 
this option.

•	 Document Is Tagged PDF. Flags the PDF as a tagged document. Deselect to 
remove the flag.

•	 Highlight Content. When selected, causes highlights to appear around 
content in the document pane when selecting the related tag in the Tags 
tab. The default option is on.

•	 Show in Content Panel. Shows the Selected tag’s contents in the Content 
panel.

•	 Show Metadata. Opens a read-only dialog box that contains reference 
information about the selected tag.

•	 Properties. Opens the Object Properties dialog box.

Create a New Child Tag

From the Tags panel:

1.	 Select the node the tag should appear inside.

2.	 Choose New Tag from the Options menu.

3.	 Select the appropriate tag type from the Type pop-up menu, or type a 
custom tag type, title the tag (optional).

4.	 Select the OK button . 

Add Tags to Comments

When tags are added to a PDF that includes comments, the comments are tagged as well. 
However, if comments are added to a PDF that’s already tagged, comments are untagged unless 
comment tagging is enabled first. 

Note: 	 To Enable comment tagging in a PDF, in the Tags panel, choose Tag Annotations 
from the Options menu. Comments or markups that are added to the PDF are 
tagged automatically. 

If a document contains untagged comments, they can be located in the logical structure tree and 
tag them by using the Find command in the Tags panel.

1.	 In the Tags panel, choose Find from the Options menu. 

2.	 In the Find Element dialog box, choose Unmarked Comments from the Find 
pop-up menu, and click Find. 
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3.	 When the comment type appears in the Type field (for example, Text), 
activate Tag Element, choose Annotation from the Type pop-up menu in 
the New Tag dialog box, and then activate the OK button. 

4.	 In the Find Element dialog box, activate the Find Next button to locate and 
tag all comments, and then activate the Close button. 

Add Links or Form Fields

Links and form fields should have already been added to the document with the appropriate 
tags if the previous steps in this document were followed. However, if the form fields or links 
were already present and tags already existed in the document, use the following steps to 
make the form field or link accessible. It is NOT enough to simply place the content under a 
link or form tag in the tags tree -- an appropriate object tag must also be present as a child of 
the parent link or form tag in the tree along with the corresponding text node.

From the Tags panel:

1.	 Locate the parent element in the tree to insert the desired link or form 
field (if the appropriate node does not exist create it first).

2.	 Choose Find from the Options menu.

3.	 In the Find Element dialog box, choose “Unmarked links” to find and tag 
links or “Unmarked annotations” to find and tag form fields from the Find 
pop-up menu.

4.	 Select the Find button.

5.	 If the item is located, activate the Tag Element button.

6.	 In the Find Element dialog box, select the Find Next button to locate and 
tag all comments.

7.	 Select the Close button.

Correct Table Tags with the Tags Panel

Use the Touch Up Reading Order tool to make sure that tables are tagged correctly. If it is 
necessary to structure figures and text within the cells of the table, it may be preferable to re-
create the table in the authoring application before converting it as an accessible PDF. Adding 
tags on a cell level in Acrobat is a labor-intensive process.

Before making any changes to table elements, use the Touch Up Reading Order tool to 
determine that the table is tagged correctly.

Check and Edit Table Elements

1.	 In the Tags panel, expand the tags root to view a table tag. 

2.	 Select the table tag <Table> and verify that it contains one of the following 
elements: 

•	 Table Rows <TR>, each of which contains Table Header <TH> or Table 
Data <TD> cells

•	 <THead>, <TBody>, or <TFoot> section, each of which contains Table 
Rows (The Table Rows contain <TH> cells, <TD> cells, or both). 

Do one or more of the following: 



Adobe® Acrobat® XI Pro Accessibility Guide: Best Practices for PDF Accessibility

Acrobat XI Pro PDF Accessibility Repair Workflow

75

•	 If the tag for the table doesn’t contain these elements, but rows, columns, 
and cells appear in the table in the document pane, use the Touch Up 
Reading Order tool to select and define the table or individual cells.

•	 If the table contains cells that span two or more columns or rows, set 
ColSpan or RowSpan attributes as appropriate for these cells in the Table 
Editor of the Touch Up Reading Order tool.

•	 Re-create the table in the authoring application, and then convert it to a 
tagged PDF.

Set ColSpan and RowSpan Attributes

ColSpan, RowSpan, Scope, and Table IDs and Headers should be set using the Touch Up Reading 
Order tool. These properties can also be set in the Object Properties dialog of a tag. To set the 
RowSpan or ColSpan properties:

1.	 In the Tags panel, select a <TD> or <TH> element. 

2.	 Choose Properties from the Options menu. 

3.	 In the Object Properties dialog box, click the Tag tab, and then activate Edit 
Attribute Objects. 

4.	 Select Attribute Objects, and then click New Item to create a new Attribute 
Object Dictionary. 

5.	 Expand the new dictionary.

6.	 Select the Layout attribute.

7.	 Activate the Change Item button. 

8.	 Change the Layout value to Table. 

9.	 Select the Attribute Object Dictionary.

10.	 Activate the New Item button.

11.	 In the Add Key And Value dialog box, type ColSpan if the cell spans multiple 
columns or RowSpan if the cell spans multiple rows.

12.	 Enter the number of columns or rows spanned in key field.

13.	 In the Value field, choose Integer from the Value Type pop-up menu.

14.	 Activate the OK button. 

Set the Language for Specific Text

When a language is set for an element in the tag tree that language applies to all content under 
the tag. If the different language is part of the same tag it must first be split out into a separate 
tag. An easy way to do this is to create a new Span tag below the current element and then 
arrange the text content under the current tag in the appropriate location.

1.	 Select the text node that must be split.

2.	 Activate the context menu and choose New Tag.

3.	 Choose Span and Activate the OK button.

4.	 Select the new span tag.
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5.	 Activate the “Selection tool for text and image” on the Acrobat toolbar.

6.	 Select the text in a different language in the document pane.

7.	 Right click or activate the context menu on the new span element.

8.	 Choose “Create Tag from Selection”.

9.	 Reorder any text that appears after the span element so it appears after 
the span element (the text should appear as two separate text nodes 
under the parent element as siblings of the span element).

To set the language:

1.	 Select the tag in the Tags tree that contains the content in a different 
language.

2.	 Right click to activate the context menu.

3.	 Choose Properties from the Options menu.

4.	 Select the Tag tab of the Object Properties dialog.

5.	 Select a language from the Language drop-down.

6.	 Activate the Close button.

Note: 	 The language that is specified for an element also applies to all elements nested 
under it in the logical structure tree.

Step 8: Add Alternative Text

Add Alternate Text and Supplementary Information to Tags

Some tagged PDFs might not contain all the information necessary to make the document 
contents fully accessible. For example, to make a non-text document content available to a 
screen reader, the PDF should contain alternate text for figures and replacement (actual) text for 
some links, formulas and abbreviations.

There are several ways to add alternative text to images and figures:

•	 The “Set Alternative Text” command in the Accessibility tool

•	 The “Set Alternative Text” command in the Make Accessible Actions 
wizard

•	 The Touch Up Reading Order tool (refer to “Add Alternate Text with the 
Touch Up Reading Order Tool” on page 61).

•	 The alternative text field of the Object Properties dialog in the Tags panel

Note: 	 Alternate/Actual text should be short and concise. The Alternative Text field 
should be used to set alternative text for figure elements. The Alternative Text 
field is not announced by screen readers for non-image element. The Actual Text 
field is announced instead when it is present on a text element.
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Add Alternate Text to a Figure

To add alternative text to a figure using the Set Alternative Text command:

1.	 Activate the “Set Alternative Text” command from the Accessibility tool 
pane or from the Make Accessible wizard.

2.	 Enter short but descriptive alternative text for each image.

•	 Decorative images can be marked as decorative in this wizard, which 
will make the image an artifact.	

Note: 	 The “Set Alternative Text” command in the Accessibility tools will display the 
alternative text, if any, for all images. The same command in the Make Accessible 
Actions wizard will also allow the entry of alternative text for images that are missing 
alternative text.

To add alternative text to a figure using the Tags panel:

1.	 Choose View > Show/Hide > Navigation Panels > Tags. 

2.	 Expand the logical structure tree to find and select the desired <Figure> tag 
element for the image. 

3.	 Choose Properties from the Options menu in the Tags panel.

4.	 In the Object Properties dialog box, click the Tag panel.

5.	 Type text in the alternative text field that describes the figure. 

Add Actual/Alternate Text to Links

When a link contains a URL, screen reader will announce the URLs of web links. However, 
meaningful alternate text for links can be much more useful. Alternative text is also useful 
for links that have the same link text and or link text that is not descriptive when taken out 
of context. For example, a link with text of “http://www.adobe.com/accessibility/products/
acrobat/” could be presented using an Actual Text property of “Acrobat accessibility page at 
adobe.com”.

Note: 	 Actual text must be added only to tags that do not have child tags. Adding actual text 
to text links or alternate text to an image link’s parent tag prevents a screen reader 
from reading any of that tag’s child tags. 

Add alternate/actual text to the <Link> tag of a link.

1.	 In the Tag panel, select the <Link> (<Figure> for image link) tag for the 
link to add actual text to and choose Options > Properties.

2.	 In the Object Properties dialog box, activate the Tag tab.

3.	 Type the text in the “actual text” field for the text links, or type text in the 
“alerntaive text” field for image links.

4.	 Activate the Close button.
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Add Actual Text for an Abbreviated Term, Forumla, or Non-Unicode Symbol

It may be useful to provide expansion text for some abbreviations, particularly when assistive 
technologies may mispronounce an abbreviation, or where formulas or non-Unicode symbols 
are used.

In the Tags panel:

1.	 Locate the term to provide actual text for by performing one of the 
following:

•	 Expand the tag tree as needed to see the elements that contain the 
abbreviation.

•	 Use the Touch Up Text tool or the Move to or Make Changes to 
Object tool to select the item in the document.

2.	 Choose Find Tag From Selection from the Options menu to locate the text 
in the tag tree.

3.	 If the abbreviation includes additional text, cut the additional text and 
place it in a new <Span> child tag within the same <Span> parent tag.

4.	 Choose Properties from the Options menu of the Tag tab.

5.	 Type the actual text for the item in the Actual Text field.

6.	 Activate the Close button.

Step 9: Use the Accessibility Checker to Evaluate the PDF File
After all the previous steps have been performed, the PDF file must be checked using the Adobe 
Acrobat XI Pro Accessibility Checker. See the document “Adobe Acrobat XI Pro Accessibility 
Guide: Using the Accessibility Checker” for instructions on how to use the Accessibility Checker.

The Accessibility Checker tool can help to identify areas of a document that may be in conflict with 
Adobe’s interpretations of the accessibility guidelines referenced in the application and its 
documentation. However, these tools do not check documents against all accessibility criteria, 
including those in such referenced guidelines, and Adobe does not warrant that documents comply 
with any specific guidelines or regulations.

Additional Functional Validation Techniques

The Accessibility Checker can evaluate many of the technical requirements for accessibility. 
The best way to test the functional accessibility of a document is to use the document with 
the same tools that readers will use. It is recommended to review the document with assistive 
technologies including a screen reader. Even when a screen reader is not available, the following 
methods provided by Acrobat should be used to check the accessibility of a PDF file:

Use Reflow view to quickly check reading order:

1.	 Activate the View > Zoom > Zoom Text menu.

2.	 Enter 200 in the Zoom field.

3.	 Activate the View > Zoom.

4.	 Activate the Reflow option.

5.	 Verify that all content appears in the correct order.

6.	 Verify that all content is readable while zoomed.
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Use the Read Out Loud to experience the document as it will be heard by readers who use this 
text-to-speech tool:

1.	 Activate > View > Read Out Loud > Activate Read Out Loud

2.	 Activate > View > Read Out Loud > Read this page only

3.	 Verify that all page content is announced in the correct order.

4.	 Repeat for each page.

Save the document as accessible text and then read the saved text file in a word-processing 
application to experience the document as it will be experienced by readers who may emboss 
the document in Braille.

1.	 Activate File > Save as > Text Plain (.txt).

2.	 Select the desired location.

3.	 Activate the Save button.
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Adobe Acrobat XI Pro’s form creation tools make it simple to create interactive form fields that 
are accessible to users with disabilities, including those with visual impairments and mobility 
impairments. This is typically achieved by adding properly structured fillable fields to the PDF 
file, setting a tab order to control a logical sequence, and by adding tooltips to fields providing an 
accessible label and instructions to users of assistive technology. 

To determine if a PDF document should be an interactive form, examine the file for the 
presence of form fields, or areas in the document where users are asked to provide information 
that you would like to collect. If the form contains these qualities, the document can be 
made electronically fillable, allowing users to complete the form online. Many people with 
disabilities can fill out electronic forms unassisted, which is a huge advantage over print forms. 
An accessible electronic form can provide privacy, security, and independence to users with 
disabilities.

There are several items to be aware of when creating accessible electronic forms. Specifically, 
authors must provide:

•	 accessible and on-screen labels

•	 	instructions (including field constraints and requirements)

•	 	a logical tab order

•	 	no keyboard traps or non-user initiated changes in focus

•	 	error identification and suggestions (when known)

•	 	error prevention for legal or financial information

These must be provided in a way that is available to all users, including those using assistive 
technology. For example, using the Tooltip property value, it is possible to add text to a check 
box on an RSVP that users can use to indicate their intention to attend an awards dinner. The 
tooltip could be set to “I plan to attend the awards dinner” which will be announced to someone 
who is blind or visually impaired via a screen reader. When form objects are used in Acrobat, 
the object’s type (such as Check Box), and state (checked or unchecked) will also be exposed to 
assistive technologies. This document describes the various types of form objects and provides 
implementation strategies for accessibility in electronic forms.

Note: 	 The techniques in this document are limited to the accessibility issues involved 
with creating form fields with the Acrobat XI Pro form tools. For a more detailed 
discussion of PDF forms including forms created with the Adobe LiveCycle 
Designer or the Adobe Digital Enterprise Platform Designer, refer to the Acrobat 
XI Pro online help. 
 
Adobe FormsCentral (https://formscentral.acrobat.com) is another option for 
creating accessible online forms to collect responses.

Acrobat XI Pro Accessible Forms and Interactive 
Documents
Create interactive forms that can be used by anyone, ensuring privacy 
and independence for all

Adobe Acrobat XI  Accessibility Accessible PDF Forms
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Types of interactive PDF Form Fields
A PDF form created with Adobe Acrobat XI Pro’s forms editing tools can contain the following types of fields:

Text field

Allows the user to type in text, such as name, address, or phone number.

Check box

Presents yes-or-no choices for individual items. If the form contains 
multiple check boxes, the user can typically select as many or few of these 
as needed.

Radio button

Presents a group of choices from which the user can select only 
one item from the group. All radio buttons with the same name work 
together as a group.

List box

Displays a list of options the user can select. List boxes have a field 
property that lets the user Shift-click or Control-click to select multiple 
items on the list.

Combo box

Allows the user either choose an item from a pop-up menu or type in a 
value.

Button

Initiates a change on the user’s computer, such as opening a file, 
playing a sound, or submitting data to a web server. These buttons can 
be customized with images, text, and visual changes triggered by mouse 
actions. Action buttons are different from radio buttons, which represent 
data choices made by the user.

Digital signature field

Allows the user to electronically sign a PDF document with a digital 
signature.

Barcode

Encodes the input form selected fields and displays it as a visual 
pattern that can be interpreted by decoding software or hardware 
(available separately).

Automatic Field Detection using the Acrobat Form Wizard

The Form Wizard in Adobe Acrobat XI Pro can be used to create interactive forms from an 
existing electronic document (for example a Word, PDF, or Excel document) or from a paper 
form that was placed in a scanner with the resulting image opened in Acrobat. Authors can also 
create forms manually in Acrobat, or individually add form fields to an existing document using 
the form tools.

Acrobat’s automatic form field detection will attempt to locate any labels that are adjacent to 
the form field (text, check box, etc.) and use any labels it finds as the source for the accessible 
label (the form field  tooltip in Acrobat). A form element and form objects for each field will be 
created in the Tags pane as part of this process. Examine the document carefully to verify that 
Acrobat accurately detected the fields and labeled them properly.

To make an electronic form fillable with the wizard:
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1.	 Display the Forms Pane 

Select View Menu > Tools > Forms (The keyboard accelerator sequence 
for displaying the Forms Task Pane is Alt + V + T + F)

Figure 48.  Figure 1. Create Form Command in the Forms Task Pane

2.	 Select the Create command 

The Keyboard Shortcut is Shift + Ctrl + 7.  

3.	 The Create Form dialog is displayed 

Figure 49.   Acrobat X Pro Create or Edit Form Dialog

Acrobat XI Pro Create Form Dialog

From the Create Form Dialog, select one of the following options and then follow the on-screen 
instructions. 
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Use an existing file

This option converts an existing electronic document (for example Word or 
PDF) to an interactive PDF form. To use the document that is currently on 
display, select “Next” and the “Use the current document” option. Select 
“Next” again. Acrobat automatically searches for and creates any form 
fields it detects, and places the document in Form Editing Mode. (Refer to 
“Figure 3. Adobe Acrobat XI Forms Editing Mode” on page 83).

Scan a paper form

This scans a paper form and converts it to a PDF form. The form will be 
scanned, converted to PDF and Acrobat will search for and create any 
form fields it detects. The form is placed in Form Editing Mode (Refer to 
“Figure 3. Adobe Acrobat XI Forms Editing Mode” on page 83).

Create a form from scratch or using a template

This creates an Online Form using Adobe FormsCentral. Adobe 
FormsCentral provides a simple interface to create interactive forms for 
collecting data online. FormsCentral is not addressed in this document.

When either the “Use an Existing File” or “Scan a paper form” option is chosen, Acrobat XI Pro 
analyzes the document, adds any detected form fields, and puts the document in Forms Editing 
Mode. The document will look similar to what is shown in “Figure 3. Acrobat XI Pro Forms 
Editing Mode” below. From here, you can add, edit or delete the automatically created form 
fields.

Figure 50.  Acrobat XI Pro Forms Editing Mode

During form field detection, Acrobat may have missed some fields, or created unnecessary ones. 
It may also have created fields of the wrong type. Verify the fields and field names on the form. 
Add New Field on the Forms Editing toolbar can be used to add more fields. You can also right-
click on the form to add, edit, or delete fields.

Creating a Form without the Forms Wizard

Form Editing Mode can also be enabled without using the Form Creation Wizard.

1.	 Select View Menu > Tools > Forms and select the Edit command under 
the Forms Tool Pane 

The Keyboard shortcut is Shift + Ctrl 7. 
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2.	 The Add or Edit Form Fields dialog is displayed if form fields have not 
been added to this document. 

Figure 51.  Acrobat XI Pro Add or Edit Form Fields Dialog

Answering “Yes” to the Add or Edit Form Fields dialog question “Do you want Acrobat to detect 
form fields for you?” causes the automatic detection of form fields prior to placing the document 
in Form Editing Mode. This is the same as running the Form Wizard. 

Acrobat will analyze the document, add detected form fields and put the PDF form in Forms 
Editing Mode. From there, you can edit the automatically created fields or add new ones. (Refer 
to “Forms Editing Mode” on page 836.)

During form field detection, Acrobat may have missed some fields, or created unnecessary ones. 
It may also have created fields of the wrong type. Verify the fields and field names on the form. 
Add New Field on the Forms Editing toolbar can be used to add more fields. You can also right-
click on the form to add, edit, or delete fields.

Answering “No” to the Add or Edit Form Fields dialog question “Do you want Acrobat to detect 
form fields for you?” also places the document in Form Editing mode, but does not create form 
fields automatically. Form fields will have to be added manually. 

Create Form Fields Manually

If you answer “No” to “Do you want Acrobat to detect Form Fields for you?”  (Refer to “Figure 2. 
Acrobat XI Pro Create or Edit Form Dialog” on page 82), the document enters Forms Editing 
Mode without automatically creating any fields. 

To add new form fields to the PDF, select one of the options from the Add New Field drop-down 
menu that presents the eight possible Acrobat field types. 

Forms Editing Mode

In Forms Editing Mode, you can add, edit or delete any existing form object.

The Acrobat XI user interface changes when in Forms Editing Mode (Refer to “Figure 3. Adobe 
Acrobat XI Forms Editing Mode” on page 83). The Forms Editing Toolbar appears and provides 
access to the Select Object tool, the Add New Field buttons for each field type, and the Form 
Preview button. On the right hand side of the Forms Editing Toolbar, beneath the Tasks pane, 
the Add New Field, Distribute, Track, and Other Tasks commands are displayed. The Fields 
pane shows any interactive fields that are currently part of the form. You can exit this mode by 
selecting the Close Forms Editing button above the Tasks pane.

Selecting a New Form Field to Create

In Acrobat XI Pro, a form field can be created by choosing one of the form tools. For each field 
type, it is possible to set a variety of options through the form field Properties dialog box. 

The forms tools can be accessed in one of three ways:

•	 Select “Add New Field” under the task pane.
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Figure 52.  Acrobat XI Add New Field Command

•	 Select one of the commands from the Forms toolbar that appears below 
the Acrobat XI Pro menubar.

Figure 53.  Acrobat XI Forms Tools Icons

•	 Right click over the form to add new fields.

Figure 54.  Adobe Acrobat XI Right Click Forms Dialog

Positioning and Naming the New Form Field

Once a form tool has been selected, a crosshair cursor appears, and a blue region defines the 
outline of the form object selected for placement.

•	 	On the page, click where the field is to be added. A field with a default 
size. To create a field using a custom size, drag a rectangle to set the 
dimensions of the field. 
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•	 	In the Field Name box, type the name of the field. Select a name that is 
relevant and descriptive to make organizing and collecting the data easier. 
This name is not shown to users of the form.

Figure 55.  Field Name Box

To test the form, select the Preview button at the top of the document window. Preview lets 
you view a form the way a form recipient would, and gives the author a chance to verify the 
appearance and behavior of the form. If a form is being previewed, click the Edit Layout button 
to return to Forms Editing Mode.

Next, set the accessible name for the field. This is how the field will be announced by assistive 
technology. Other properties such as required field notation can also be set here.

Note: 	 If the “Keep Tool Selected” option is checked in the forms toolbar, the Field 
Name box doesn’t appear after adding a field. Each time the page is clicked, 
a new field is added to the form. To exit this mode, press the Esc key or click 
the Select Object Tool button. To modify the properties of a field, double-click 
it.

Form Field Properties

How a form field behaves is determined by settings in the Properties dialog box for that 
individual field. Properties can be set that apply formatting, determine how the form field 
information relates to other form fields, impose limitations on what the user can enter in the 
form field, trigger custom scripts, and so forth.

To modify a field’s properties, right-click it (or select and then press the Application key).

A variety of properties can be set for an Acrobat form field, depending on the form field type. 
The properties for each type of form field are selected on a series of tabs. When a property is 
changed, it is applied as soon as another property is selected or when Enter is pressed.

All form field types have a General tab, Appearance tab, and an Actions tab. Other tabs appear 
only in specific types of form fields. The Options tab appears for most form field types, but the 
options available are unique to each type of form field.

You can leave the Properties dialog box open if you want to change multiple fields at once. 

Setting Tooltips for Form Fields

The tooltip field on the General tab of the field properties dialog is the most important item for 
form fields. The content of the tooltip will be announced by screen readers as the accessible 
name of the field. This property provides the user with information and instructions about the 
field. Tooltips should be short and descriptive and should not include the type of field or text 
such as “Click to enter”.  For example, “First Name” would be a good tooltip for a first name 
field and “Sign-up Date (2 digit month / 2 digit day / 4 digit year) would be a good name for a 
“Sign up date” field that had a required field format.  The City field for a group of shipping field 
would need to include the group name as well as the on-screen label, “Ship to City” or “Shipping 
Address City”. (Refer to “Figure 9. Adding a Tooltip to a Form Field” on page 87).
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Note: 	 Note: The tooltip also displays text that users may find helpful in filling in the form 
field. Tooltips appear when the pointer hovers briefly over the form field. 

To set the tooltip property of a form field:

1.	 Ensure Forms mode is active

Activate Forms Tool > Edit 

2.	 Ensure that the Select Object tool is selected from the toolbar

3.	 Open the field properties dialog

•	 Double-click a selected form field; or

•	 Right click or select and press the applications key and select 
properties; or

•	 Select the desired field and press the shortcut keystroke (Control+I)

4.	 Enter a short and concise label into the tooltip field.

The tooltip should provide any group label for a group of fields along 
with the field’s label (refer to the special instructions for radio button 
groups in the next section Tooltips for Radio Buttons).

Figure 56.  Adding a Tooltip to a Form Field

Tooltips for Radio Buttons

To create a radio button group, where only one field can be selected at a time, assign each field 
the same name and the same tooltip, but provide different Button Choices (values). The radio 
button choice is a field in the Options tab of the Radio Button Properties dialog.  The tooltip and 
button value will be announced to users of assistive technology for each radio button.  When the 
same radio button name is assigned to a radio button, the tooltip field should automatically be 
populated with the tooltip text from the other radio buttons in the group. (Refer to “Figure 10. 
Identical Name and Tool Tip Value for a Radio Button Group” on page 88).

For example, create a radio button group that asks the question, “Conference Pass”.
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Create four radio buttons. For each button, choose to give the button the identical name, 
“Conference_Pass.” For each radio button, the identical text appears in the Tooltip field, such as 
“Conference Pass” 

Figure 57.  Setting Identical Name and Tool Tip Value for a Radio Button Group

For the button next to the label indicating “1-day Pass”, enter “1-day Pass” in the Radio Button 
Choice field under the options tab in the Radio Button Properties dialog. 

Figure 58.  Setting the Radio Button Choice

Editing or Modifying an Existing Form Field

Acrobat form field properties can only be accessed in editing mode (by choosing Forms > Add 
New Field or Edit Fields). Properties for multiple form fields can be set at once. 

1.	 To edit multiple form fields, select the fields to edit.

Hold down control and click each field to select 

2.	 Right-click/Control-click one of the selected fields, and choose Properties. 

Change the properties on each of the available tabs, as needed. The 
property is changed as soon as another property is selected or Enter is 
pressed.

3.	 Activate the Close button or press enter to close the Properties dialog 
box. 

If form fields are selected that have different property values, some options in the Properties 
dialog box are not available. Otherwise, changes to the available options are applied to all 
selected form fields. 

Note: 	 To avoid accidental changes to the form field, select Locked in the lower left 
corner of the Properties dialog box before it is closed. To unlock, click the check 
box again.

Deleting a Form Field

With the document in Forms Editing mode, click on the field to delete and do any of the 
following:

•	 Right-click and select Delete

•	 Press the Delete key.
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•	 From the menu, select Edit > Delete (ALT + E, D)

Note: 	 To select multiple fields hold the Control/Command key and click on each 
one.

Field Actions

There are many different actions that can be associated with a form field. These include 
actions based on mouse entry, mouse exit, mouse up, mouse down, on focus, and on blur. It 
is important to note that mouse-only actions will not be keyboard accessible. All functionality 
must be keyboard-accessible without requiring the use of a mouse. The “on focus” and “on blur” 
actions are triggered when the field receives or loses focus respectively. These actions should be 
used with caution. The “on focus” action must not move focus to another field unless the field 
is not to be used, and these actions must not be used to trap the keyboard focus within certain 
fields.

The user must be able to navigate past form fields without having the keyboard focus 
trapped. This is a requirement because many keyboard-only users, including users of assistive 
technology, use the Tab or Shift+Tab keystrokes to explore the fields of a form and discover 
what options are available. For the same reason, the option “Commit value immediately” should 
be avoided for the dropdown and list fields. Users of assistive technology often use the Up and 
Down arrows to explore or navigate to items in these fields, so changing values using these 
keystrokes can prevent them from using the form properly.

Validation and Error Messages

When form validation is used to automatically validate fields, error messages must indicate what 
fields triggered the error and provide suggestions to help the user enter the correct information. 
Error suggestions are not required when they would invalidate the purpose of the form, such 
as with a quiz. But error prevention must be provided for legal or financial transactions. Error 
prevention can involve allowing the user to review or make changes, and/or checking the 
information for errors prior to submission. Typically, the Validation tab of the field properties 
dialog is used to provide feedback to the user. One accessible solution is to provide an alert that 
indicates the error and provides a suggestion. However, error-detection mechanisms should not 
restrict the ability for keyboard users to navigate among form fields.

When audio is used to indicate an error such as entering more characters into a field than are 
allowed, a visual indication must also be provided to warn users who cannot hear the audio.

Set the Tab Order

If a PDF document does not have a specified tab order, the default order is based on the 
document structure, unless the user has deselected the Tab Order option in the Accessibility 
preferences.

The tab order can be changed after the form has been created. It has the following options:

•	 If Forms Editing mode is active, the order can be set to document 
structure (default), row, or column. 

•	 The order can also be set manually by dragging and dropping fields in the 
Fields pane. 

•	 If Forms Editing mode is not active, the order can be set in page 
properties by row or column. However, the tab order cannot be set 
manually.
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To change the tab order, first select “Order Tabs Manually” from the Tab Order button on the 
Fields pane. Then fields can be dragged and dropped where appropriate within the Fields pane 
to modify the tab order (Refer to “Figure 12. Rearranging Tab Order with the Fields Pane” on 
page page 90). To assist in determining tab order, select “Show Tab Numbers” from the Tab 
Order button menu of the Fields pane (Refer to “Figure 12. Rearranging Tab Order with the Fields 
Pane” on page page 90). To see the relationship between items in the Fields pane and the 
Document pane. Note also the Order Tabs Manually and the Show Tab Numbers options are 
highlighted.

Figure 59.  Rearranging Tab Order with the Fields Pane

Provide Instructions and Onscreen Labels

It is important to ensure that all form fields have instructions or labels.  Form instructions are 
typically be placed above the form, call out required fields, and provide additional information 
on completing and submitting the form. Individual form fields typically have labels above or 
to the left of the form field, with the exception of radio buttons and checkboxes, whose labels 
should appear to the right of each field. Labels should contain any formatting information, such 
as value length or date format.

Other Accessibility Considerations

In addition to making form fields accessible, other tags and properties must be set to improve 
overall accessibility. For example, the default language of the document must be specified; 
security settings must not interfere with screen readers; links must be provided in a tagged and 
keyboard accessible manner; and the document must be tagged. This is not an exhaustive list of 
the tasks required before a form based document can be considered accessible or conformant 
to a specific accessibility standard or guideline. For a discussion on additional requirements 
including verifying conformance, refer to the Adobe® Acrobat® XI Pro Accessibility Guide: PDF 
Accessibility Repair Workflow.



For more information
Solution details: www.adobe.com/accessibility/products/acrobat/
Program details: www.adobe.com/accessibility
Contact information: access@adobe.com

Adobe Systems Incorporated 
345 Park Avenue 
San Jose, CA 95110-2704  
USA 
www.adobe.com

Adobe, the Adobe logo, Acrobat, Acrobat Connect, ActionScript, Adobe Captivate, Authorware, Flash, and JRun are either registered trademarks or trademarks of Adobe 
Systems Incorporated in the United States and/or other countries. Microsoft and Windows are either registered trademarks or trademarks of Microsoft Corporation in the  
United States and/or other countries. Java is a trademark or registered trademark of Sun Microsystems, Inc. in the United States and other countries. All other trademarks  
are the property of their respective owners.
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